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Preface 
 
The Construction Industry Council (CIC) is committed to seeking continuous 
improvement in all aspects of the construction industry in Hong Kong. To achieve 
this aim, the CIC forms Committees, Task Forces and other forums to review specific 
areas of work with the intention of producing Alerts, Reference Materials, Guidelines 
and Codes of Conduct to assist participants in the industry to strive for excellence. 
The CIC appreciates that some improvements and practices can be implemented 
immediately whilst others may take more time for implementation. It is for this reason 
that four separate categories of publication have been adopted, the purposes of 
which are as follows: 
 
Alerts The Alerts are reminders in the form of brief leaflets produced 

quickly to draw the immediate attention of relevant stakeholders 
to the need to follow some good practices or to implement some 
preventive measures in relation to the construction industry. 
 

Reference 
Materials 

The Reference Materials are standards or methodologies 
generally adopted and regarded by the industry as good 
practices. The CIC recommends the adoption of the Reference 
Materials by industry stakeholders where appropriate. 
 

Guidelines The Guidelines provide information and guidance on particular 
topics relevant to the construction industry. The CIC expects all 
industry stakeholders to adopt the recommendations set out in 
the Guidelines where applicable. 
 

Codes of 
Conduct 

The Codes of Conduct set out the principles that all relevant 
industry participants should follow. Under the Construction 
Industry Council (Cap 587), the CIC is tasked to formulate codes 
of conduct and enforce such codes. The CIC may take necessary 
actions to ensure compliance with the codes. 

 
If you have read this publication, we encourage you to share your feedback with us. 
Please take a moment to fill out the Feedback Form attached to this publication in 
order that we can further enhance it for the benefit of all concerned. With our joint 
efforts, we believe our construction industry will develop further and will continue to 
prosper for years to come. 
 
  



 

Foreword 
I am glad to see the release of CIC BIM User Guide for Preparation of Statutory 
Plan Submissions Revit (December 2020). This software specific user guide shall 
be read in conjunction with the CIC BIM Standards for Preparation of Statutory 
Plan Submissions (December 2020).  

This software specific user guide is only provided to demonstrate the feasibility of 
drawings generation with the Standards.  

With the software specific user guides which contains step by step procedures of 
modelling, BIM users can easily apply the templates for the generation of statutory 
plan submission drawings. 

Feedback on the CIC BIM User Guide for Preparation of Statutory Plan Submissions 
Revit (December 2020) from practitioners subsequent to the issuance of this 
publication will be considered in future revisions.  

On behalf of the CIC, I would like to thank everyone who has contributed to 
producing this CIC BIM User Guide for Preparation of Statutory Plan Submissions 
Revit (December 2020), in particular to the members of the Task Force on BIM 
Standards. 

 

Ar. Ada FUNG, BBS 

Chairperson  

Committee on Building Information Modelling 

Construction Industry Council 

December 2020 
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1 Hardware / System Requirements 
 

1.1 General 
 

Hardware / system requirement for modellings, coordination and 
visualisation on desktop/notebook computers and mobile devices 
should be determined by the BIM managers for different projects on 
a case by case basis. The minimum requirement varies for different 
applications, project sizes and operating systems. 
https://www.autodesk.com/collections/architecture-engineering-
construction/included- software 

  

http://www.autodesk.com/collections/architecture-engineering-construction/included-
http://www.autodesk.com/collections/architecture-engineering-construction/included-
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2 Revit Basics 
 

2.1 User Interface 

− Open a project or family or create either one from a template to get 
started. The user interface provides the tools need to work in a model. 
The user interface can customise the interface to support the way for 
different works. 

− Project Browser: organise the views, schedules, and sheets of the current project. 
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− Properties palette: modify properties of select elements. 
 

− Ribbon: select the tools need to design the building model. 

 
−  View Control Bar: provide options for changing the view display, 

including scale or visual style. 

 
2.2 Difference of RVT, RTE, RFA files 

It will eventually become necessary to save our work and share our progress 
with others in the model. RTEs are project template file. RVTs are working 
project files. Both files can be generated from Revit® projects. The difference 
is that the template is used when you start a new project.  

RFAs are family files that can either be loaded into a project or saved 
externally.  
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2.3 Types of Family (system families, loadable families, in place family) 

A group of elements with common parameters and graphical representation call 
family. There are three types of families in the model, system families, loadable 
families and in-place families. 

System Families 

System families are basic elements to assembly on a construction site. It can 
be predefined in the model, for example: wall, ceiling, beam and duct. 

Loadable Families 

Loadable families are families used to create non-standard or customised 
components such as windows, furniture, pump and chiller. It includes 
customisation of annotation elements, such as symbols and title blocks. 

In-Place Families 

In-place elements are unique elements for a specific project. It can be created 
in-place geometry or import to other projects to resize the shape. 

 
2.4 Categories and Types 

Category assigns the properties of a predefined family category to the 
component.  

Types define components that apply across all types in that family. 

 
2.5 Project base point, Grid, Levels and Work Planes 

Project base point defines the origin (0,0,0) of the project coordinate system 
initially. Location of point can be determined by the team as a reference 
point. It can be used to establish a reference for measuring distances and 
positioning objects in relation to the model and used to position the building 
on site. 

Gridline, annotation element help to determine whether gridlines appear in 
each plan view that you create for a project.  

Level can act as a reference for level-based elements for story or reference 
plane within a building. In a section view or elevation view, it can add a level 
line in a model and create an associated plan view.  

Work plane defines a virtual 2-dimensional surface used as the origin for 
viewing or for sketching in the model. It can create on Architecture / Structure / 
System tab. 

 
2.6 Suggested Model Nesting Method 

When you import a model that contains a linked model, links become nested. 
Nested linked models can be shown or hid in the host model. The nested links 
display according to Reference Type setting in the host model. 

1. Overlay -  unload  nested models into the host  model, do  not  display in the project 

2. Attachment - load nested linked models in the host model, displays in the project 
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2.7 2D Views and Sheets 
2D views are oriented to specific coordinates such as plan, elevation and 
section. Schedule and details are another way of viewing information in 
neither 2D nor 3D. A new view can be generated from the Create panel on 

View tab of the ribbon. 
 

Or you can right-click a view name in Project browser and select one of the 
Duplicate View commends. 

 
 

After creating a model in Revit, you can print the sheets by creating viewport 
for collecting documents. A sheet set consists of many sheets. Layout, 
elevation, section, schematic, details, schedule, legend etc. can be included 
in the sheet set. 

 
2.8 Tag, Symbols and Dimensions 

Tag is an annotation (text label) to identify elements in a drawing. Tag is 
intelligent, bi-directional graphics that report information stored in an object’s 
properties. Once you have tagged an element and entered a value in the tag, 
the tagged element will retain that value until you remove it. 

 

The symbol is a graphic representation of an annotation or other object. 
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Dimensions are used to convey the distance or angle between elements or 
part of elements. It is a bi-directional annotation that you can edit the distance 
directly within the dimension string to move elements a specific distance apart 
and updates automatically. There are permanent dimension and temporary 
dimension can be used in the model. 

 
 

2.9 Different Parameters 
All contents in the model have parameters, which are simply the information or 
data about the objects/ items. 

Parameters that you create display in the Properties palette or Type 
Properties dialogue under the group you define and with the values you 
define. 

Project Parameters - specific to a single project file and cannot share with 
other projects. They are added to elements by assigning them to multiple 
categories of elements, sheets, or views. It can be used for sorting, 
scheduling, and filtering. 

Family Parameters - control variable values of the family, such as materials. It 
is specific to the family. 

Shared Parameters - can be used in multiple families or projects. After you 
add a shared parameter definition to a family or project, you can use it as a 
family or project parameter. Because the definition of a shared parameter is 
stored in a separate file, it is protected from change. So, it can be tagged and 
scheduled. 

Global Parameters - specific to a single project file but are not assigned to 
categories. It can be simple values, values derived from equations, or values 
taken from the model using other global parameters. 
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3 Getting Start 
In this chapter, it covers how to configure and manage standards through the 
development and use of a project template. This template can be rich with 
information that goes beyond the out of box content that Revit provides. The 
template setting is established and content as well as explain how the reuse 
of work will increase productivity and standardise with each project for 
Building Department submission. 

1. Open a new project in Revit by the following steps: 

Open Revit ➜ click “New” button ➜ click “Browse” in New Project browser to 
open template (CIC_Template_STR.rte for Superstructure Plans; 
CIC_Template_DML.rte for Demolition Plan; CIC_Template_CVL.rte for 
Hoarding Plan) ➜ click “OK” 
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2. Create Site Boundary 

In the project browser, click “Site” plan under the Structural Plan of View. 
 

Insert CAD drawing of block plan to the view, click “Insert” ➜ “Link CAD” 
 

Move the CAD link towards the location of the project base point such that point 
A of the site boundary and the project base point is overlapped. 

 

Open a structural plan in Revit, click “Massing & Site” ➜ “Modify Site” ➜ 
“Property Line” to add property line. 
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Add site boundary symbol in plan view (Refer to section 7.1.4 Add annotation 
symbol) 

 

Category Family Type 

Generic 
Annotation 

ANN-GNN-CIC-
Site_Boundary_Mark 

/ 

 
3. Set the project base point (for civil model only): 

Inside Site Plan ➜ Click “Manage” in ribbon ➜ “Project Location” ➜” 
Coordinates”➜ click “Specify Coordinates at Point”. 

Select one of the site boundary points. In the dialogue box, type the true 
coordination of the point. 
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In the same view, select the survey point, click the clip to change its state to 
unclipped. 

 
Move the survey point towards the project base point so that they are 
overlapped. Then click the clip to change its state to clipped. 

 
 

4. Create a grid and level 

Open a structural plan in Revit, click “Architecture” ➜ “Datum” to create a grid in 
the model according to a specific design. 

 
 

Open an elevation in Revit, click “Architecture” ➜ “Datum” to create a level in 
the model according to a specific design. 
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5. Acquire a shared coordinate system from the civil model (for structure and demolition 
models only) 

In the project browser, open Level 0 plan under Structural Plan of View. Insert CAD 
drawing of block plan to the view, click “Insert” ➜ “Link CAD” 

 

Move the CAD link towards the location of the project base point such that the 
intersection of Grid A and Grid 1 is placed in the project base point. 

 
 

Create grids and site boundary. 
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Link civil model file to the view, click “Insert” ➜ “Link Revit” 

 
 

Move and rotate the civil model so that their site boundary and grids are 
overlapped. 

 

 

Select the civil model, in the properties panel, click “Not Shared” in “Shared Site” 
➜ select “Acquire the shared coordinate system form xxx.rvt” -> click 
“Reconcile”. 

 

 
Select the survey point, click the clip to change its state to unclipped. 

 
Move the survey point towards the project base point so that they are 
overlapped. Then click the clip to change its state to clipped. 
Save the project.  
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4 Creating Model Objects 
 

4.1 Superstructure 
The following objects will be modelled in the structural plan: 

  Slab 

  Column 

  Wall 

  Beam 

  Lift Shaft 

  Staircase 

  Water Tank 

  Reinforcement 
 
 
 

4.1.1 Create a Slab 

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Floor” ➜ 
click “Floor: Structural” 

 

In the properties panel, you may choose the specific types of the slab from floor 
family or create by your own. Adjust the value for “Height Offset From Level”. 
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Create the slab by drawing boundary line ➜ select “Span Direction” ➜ click 
“tick”. 

 

 

 
 
 

Repeat the above steps. 

 
 
 

Add level difference symbol and span direction symbol in plan view (Refer to 
section 7.1.4 Add annotation symbol) 

 

Category Family Type 

Generic 
Annotation 

ANN-GNN-CIC-Level_Difference / 

Generic 
Annotation 

ANN-GNN-CIC-Span_Direction Two Way Slab - 

2.5mm One Way 

Slab  - 2.5mm 

Cantilever  Slab - 2.5mm 
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4.1.2 Create Column 

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Column”. 

 

In the properties panel, you may choose the specific types of the column from 
column family or create by your own. Adjust the value for “Base Level”, “Base 
Offset”, “Top Level” and “Top Offset”. 

 
In the properties panel, type column mark in “Mark” of identity data. For 
example, C1A was typed for column mark in this case. ➜ Place the column into 
designed location. 
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Repeat the above steps. 
 

 
 

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Structural Column ANN-SCG-CIC Mark 

 
 
 
 

4.1.3 Create Wall 

Open a structural plan in Revit ➜ Click “Architecture” in the ribbon ➜ “Build” ➜ 
click “Wall” ➜ click “Wall: Structural”. 
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In the properties panel, you may choose the specific types of the wall from 
column family or create by your own. 

 
 

In the properties panel, place the wall by setting  base constraint and top 
constraint to demonstrate the floor extension of the wall. Adjust the value for 
“Base Constraint”, “Base Offset”, “Top Constraint” and “Top Offset”. 

 
 
 

Drag the wall from the start point to endpoint. 
 

In the properties panel, type wall mark in “Mark” of identity data. For example, 
W5B was typed for wall mark in this case. 
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Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Wall ANN-WLG-CIC Mark 

Type Mark 

 
 

4.1.4 Create Beam 

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Structure” 
➜ click “Beam” 

 

In the properties panel, you may choose the specific types of the beam from 
beam family or create by your own. 
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Create the slab by drawing start point and endpoint ➜ Enter the value for “Start 
Level Offset” and “End Level Offset” or “Z Offset Value” for beam or inverted 
beam in the constraint of properties. 

 
In the properties panel, add beam mark in “Mark” of identity data. For example, 
TB18 was typed for beam mark in this case. 

In Structural group, tick the property “Cantilever” or “Transfer” to identify the 
specific beam. 

 
Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 

 

Category Family Type 

Structural Framing ANN-FRG-CIC-
Rectangular 

Standard 
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4.1.5 Create Lift Shaft 

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Opening” 
➜ click “Shaft” 

 

Create the shaft by drawing boundary line / using detail line on plan ➜ click 
“symbolic line” to create cross indication for shaft ➜ click “tick”. 

 
 

In the properties panel, enter the value for base constraint, base offset, top 
constrain and top offset to control the shaft location and level. 

 
 

4.1.6 Create a Staircase 

Open a structural plan in Revit ➜ Click “Architecture” in ribbon ➜ “Circulation” 
➜ click “Stair” 
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Click “Run” ➜ Create the staircase by drawing start point to endpoint, and 
landing on plan ➜ click “tick”. 

In the properties panel, use the base level, top-level and offset to control the 
staircase location and level. 

 

 

 
 

4.1.7 Create a Water Tank 

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ “Model” ➜ 
”Component” ➜ click “Model In-Place” 

Select “Generic Models” in the Family Category and Parameters dialogue and fill 
in the name of the water tank. 
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Draw the water tank by using “Forms” tools. 

 
 

 
 
 

4.1.8 Create Reinforcement (Beam / Column / Wall / Staircase / Water Tank) 

After the creation of Beam, Column, Wall, Staircase ➜ Open a structural plan in 
Revit ➜ right click the plan in project browser ➜ click “Duplicate View” to 
duplicate the plan ➜ click “Duplicate” 

 
 

Create column rebar plan ➜ click “View” ➜ “Graphics” ➜ click “Visibility/ 
Graphics” to show the column and rebar in plan only. 



 
23 

Unclick all items, except “Structural Column” and “Structural Rebar” in Visibility/ 
Graphics window ➜click “Apply” ➜ click “OK”. 

 

 
Only column is shown on the screen. 

 

 

Select a column ➜ click “Reinforcement” in ribbon ➜ click “Rebar”. 
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Select the “Placement Plane” in Ribbon ➜ select “current work plane / near 
cover reference / far cover reference” to place the rebar plane. 

 

Create a stirrup ➜ In the properties panel, you may choose the specific rebar 
bar and rebar shape from rebar family or create by your own. 
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Change the rebar spacing in rebar set of Ribbon. 
 

Change the quantity of rebar and direction in rebar set of Ribbon. 

 

Repeat the above step for mains and links. 

 

Repeat the above steps for Beam and Wall. 
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Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Structural 
Rebar 

ANN-RBG-CIC 
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4.1.9 Create Reinforcement (Path) 

After the creation of Slab ➜ Click “Structure” in ribbon ➜ “Reinforcement” ➜ 
Click “Path” 

 

Select the floor ➜ Sketch the line of the path on the floor. 
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In the properties panel, fill in the information of “Layout Rule”, “Additional Offset”, 
“Face”, “Bar Spacing”, “Primary Bar – Type”, “Primary Bar – Length”, “Primary 
Bar – Shape”, “Primary Bar – Start Hook”, “Primary Bar – End Hook”. 

For “Rebar Layer”, fill in T1/T2/B1/B2, etc. 

 
Select the structural path reinforcement symbol. In the properties panel, select  
“ANN-PHG-CIC-Symbol (Top)” for top layer rebar and “ANN-PHG-CIC-Symbol 
(Bottom)” for bottom layer rebar. 

 

 
Add path reinforcement symbol in plan view 

Click “Annotation” in ribbon ➜ ”Symbol” ➜ click “Path”. 
 

Select between “Top” or “Bottom” for a different layer of the rebar. 
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Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 

 

Category Family Type 

Structural Path 
Reinforcement 

ANN-PHG-CIC-
Tag 

Standard 
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4.1.10 Create Reinforcement (Area) 

After the creation of Slab ➜ Click “Structure” in ribbon ➜ “Reinforcement” ➜ 
Click “Area” 

 

Select the floor ➜ sketch the boundary of slab to form a closed loop 

 
A parallel line symbol indicates the major direction edge of the area 
reinforcement. 

For major direction, tick “Top Major Direction” and “Bottom Major Direction” in 
the properties panel. Select the “Top Major Bar Type” and “Top Major Spacing”. 
Set the value of “Bottom Major Bar Type “and “Bottom Major Spacing”, 
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Copy the previous Structural Area Reinforcement object and paste “Aligned to 
the Same Place” as the rebars for minor direction. 

For minor direction, tick “Top Minor Direction” and “Bottom Minor Direction” in 
the properties panel. Select the “Top Minor Bar Type” and “Top Minor Spacing”. 
Set the value of “Bottom Minor Bar Type “, “Bottom Minor Spacing”, “Additional 

Top Cover Offset” and “Additional Bottom Cover Offset”. 
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Go to 3D View, there are four layers of rebars. Select the first layer of rebars and 
add “T1” to Comments in the properties panel. Select the second layer of rebars 
and add “T2” to Comments. For the bottom layer of rebar, add “B2” to 
Comments for the third layer and add “B1” to Comments for the fourth layer. 

 
 

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Structural Area 
Reinforcement 

ANN-ARG-CIC Major / Minor 
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4.2 Demolition including hoarding 
The following objects will be modelled in the demolition plan: 

  Existing Building Structure 

  Bamboo Scaffolding 

  Propping 

  Debris Chute 

  Video Camera 
 
 

The following objects will be modelled in hoarding plan: 

  Topo surface 

  Counterweight 

  Hoarding 

  Railing 

  Street Furnitures (Traffic Light / Fire Hydrant / Pillar Box / Street Light) 
 
 
 

4.2.1 Create an Existing Building Structure 

Steps of creating existing building structure can be referred to Section 4.1 
“Superstructure”. Structural wall, beam, slab and shaft are created. 

 
 

4.2.2 Create Bamboo Scaffolding 

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Component”. 

 

In the properties panel, you may choose the specific types of scaffolding from 
family “GMD-TMP-CIC- Bamboo_Scaffolding” or create by your own. 
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Create the scaffolding by stretch starting point to endpoint 

 

Repeat the above steps. 
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4.2.3 Create Propping 

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Component”. 

 

In the properties panel, you may choose the specific types of propping from 
family “GMD-TMP-CIC- Propping” or create by your own. Place it to the desired 
location. 

 

 
Repeat the above steps. 
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4.2.4 Create Debris Chute 

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Component”. 

 

In the properties panel, you may choose the specific types of debris chute from 
family “GMD-TMP-CIC- Debris_Chute” or create by your own. Place it to the 
desired location. 

 

Dimension can be adjusted by clicking “Edit Type” in properties panel ➜ type 
the dimensions of width / length / height by your own to suit the design ➜ click 
“OK”. 

 



37  

 
Repeat the above steps. 

 

 
4.2.5 Create a Video Camera 

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Component”. 
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In the properties panel, you may choose the specific types of debris chute from 
family “SCD-CTV-CIC- Wall_Mounted” or create by your own. Place it to the 
desired location. 
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4.2.6 Create Topographic Surface 

Insert CAD as a reference to create a 3D topo surface. 

Open a site plan in Revit ➜ click “Insert” in Ribbon ➜ click “Link CAD”➜ find the 
CAD location ➜ click “OK” 

 

 
 

 

Open a site plan in Revit ➜ click “Massing & Site” in ribbon ➜ click 
“Toposurface” under Model Site. 

 

Place point and set the elevation on the Toposurface to create ➜ click “Tick”. 
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Repeat the above steps for other Toposurface with different levels. 
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4.2.7 Create Counterweight 

Open a site plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”. 
 

In the properties panel, you may choose the specific types of counterweight from 
family 

“STE-LGT-CIC-Counterweight-2 / 3 / 4 posts” or create by your own. Place it to 
the desired location. 

 
Repeat the above steps. 

 

 
  



42  

4.2.8 Create Hoarding 

Open a site plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”. 

 

In the properties panel, you may choose the specific types of hoarding from 
family 

“STE-LGT-CIC-Hoarding-Gantry / Double Deck / Corner” or create by your own. 
Place it to the desired location. 

Adjust Angle for the sloped surface. 

 
Repeat the above steps. 
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4.2.9 Create Railing 

Open a site plan in Revit ➜ click “Architecture” in ribbon ➜ click “Railing”. 
 

In the properties panel, you may choose the specific type of counterweight from 
family “ste-lgt-CIC- Counterweight-2 / 3 / 4 posts” or create on your own. Drag 
the railing from a start point to end. Place it to the desired location. 

 
Repeat the above steps. 
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4.2.10 Create Street Furnitures (Traffic Light/Fire Hydrant/Pillar Box/Street Light) 

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click “Component” 
 

In the properties panel, you may choose the specific types of elements from 
family or create by your own. Place it to the desired location. 

 
 
 

Repeat the above steps. 
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4.3 Foundation 
The following objects will be modelled in a foundation plan: 

  Pile Cap 

  Bored Pile 

  Socket H-Pile 

  Tie Beam 

  Screen Wall 

  Foundation Slab 

  Column/Wall above pile cap 

 
4.3.1 Create Pile Cap 

Open a pile cap level plan in Revit ➜ Click “Structure” in ribbon ➜ click 
“Foundation” ➜ click “Slab” ➜ “Structural Foundation: Slab” 

 

 
 

 
In the properties panel, you may choose the specific types of the slab from 
foundation slab family or create by your own. 
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Type slab mark in “Mark” of identity data. For example, CP1 was typed for slab 
mark in this case. 

 

 

Click “Edit Type” in Properties browser ➜ Under Type Parameter ➜ Under 
Other ➜ Select the Foundation_Type as “FD_Cap” to ensure the filtering 
function of template format can be functional. 
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Use Draw tool to create a slab by drawing a boundary line ➜ click “Tick” when 
finishing 

 

 

 
Repeat the above steps. 

 

Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Structural 
Foundation 

ANN-FDG-CIC-
Rectangular 

Mark & FDN 
Thickness 
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4.3.2 Create Bored Pile 

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Foundation” ➜ click “Isolated 

 

In the properties panel, you may choose the specific types of a pile from pile 
family “SFD-FPL-CIC- Bored_Pile” or create by your own. 

 
Type pile mark in “Mark” of identity data. For example, BP3 was typed for the 
mark in this case ➜ place the pile into the designed ocation. 

 
Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Structural 
Foundation 

ANN-FDG-CIC-Bored_Pile Mark & Size 

Mark 
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4.3.3 Create Socket H-Pile 

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Foundation” ➜ click “Isolated” 

 

In the properties panel, you may choose the specific types of the pile from pile 
family “SFD-FPL-CIC- Socket_H_Pile” or create by your own. 

Create the pile by setting cap thickness, pile length, socket length and height 
offset in constraint. The universal beam dimension and steel plate dimension of 
the pile can be set in “Edit Type”. 

 

Type pile mark in “Mark” of identity data. For example, SP2B was typed for the 
mark in this case. ➜Place the pile into designed location. 
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Repeat the above steps. 
 

Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Structural 
Foundation 

ANN-FDG-CIC-
Rectangular 

Mark Only 

 

 
4.3.4 Create Tie Beam 

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click 
“Foundation” ➜ click “Isolated”. 

 
In the properties panel, you may choose the specific types of the beam from 
family “SFD-FBM-CIC- Rectangular” or create by your own. 



51  

Click “Place on Work Plane” in Ribbon ➜ draw the beam from starting point to 
end at the centre of slabs. 

 

 

Type beam mark in “Mark” of identity data. For example, TB10 was typed for the 
mark in this case. 
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Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Structural 
Foundation 

ANN-FDG-CIC-
Rectangular 

Standard 2 Lines 

Standard 

 
 

4.3.5 Create Screen Wall 

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click “Wall”. 
 

In the properties panel, you may choose the specific types of a wall from family 
or create by your own ➜ set the “Base Constraint” and “Top Constraint” of 
screen wall height. 

Type wall mark in “Mark” of identity data. For example, BW10 was typed for the 
mark in this case. 
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Draw the screen wall from starting point to end. 

 

Repeat the above steps. 
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4.3.6 Create Foundation Slab 

Click “Structure” in ribbon ➜ click “Foundation” ➜ click “Slab” ➜ “Structural 
Foundation: Slab” 

 
 

In the properties panel ,you may choose the specific types of the slab from 
foundation slab family or create on your own. 

 

Use Draw tool to create a slab by drawing a boundary line ➜ click “Tick” when 
finishing 

 

 
 

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Structural 
Foundation 

ANN-FDG-CIC-
Rectangular 

Mark 
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Add level difference symbol and span direction symbol in plan view (Refer to 
section 7.1.4 Add annotation symbol) 

Category Family Type 

Generic 
Annotation 

ANN-GNN-CIC-Level_Difference / 

Generic 
Annotation 

ANN-GNN-CIC-Span_Direction Two Way Slab - 

2.5mm One Way 

Slab  - 2.5mm 

Cantilever  Slab - 2.5mm 
 

 
 
 

4.3.7 Create Column/Wall 

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click 
“Column”/”Wall”. 

 
 

In the properties panel, you may choose the specific types of a column from 
column family or create by your own. 
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In the properties panel, type column mark in “Mark” of identity data. For 
example, PC2 was typed for column mark in this case. ➜ Place the column into 
designed location. 

 

 
 
 

Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Structural Column ANN-SCG-CIC Mark 

Wall ANN-WLG-CIC Mark 
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4.4 Excavation and lateral support 
The following objects will be modelled in a foundation plan: 

  Sheet Pile 

  Walling 

  Struct / Tie / Short Struct 

  Stage Topo / Final Topo 

  Basement Wall 

 
4.4.1 Create Sheet Pile 

In the Project Browser, open an existing ground level Click “Structural” in ribbon 
➜ click “Isolated” 

 

In the Properties panel, select family type “SFD-FPL-CIC-Sheet_Pile” ➜ change 
“Offset” to set level ➜ 

Click “Edit Type” to change properties by your own if any 

 

Click “Place on Work Plane” ➜ Drag from starting point to end to create sheet 
pile 
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Repeat the above steps 

 
 
 

4.4.2 Create Walling 

In the Project Browser, open an existing ground level 

Click “Insert” ➜ click “Load Family” ➜ Open “SFM-STB-CIC-UB.rfa” file in 
Browser ➜ click “Open” Remark: repeat the above steps to load different types 
can be loaded into the model 

 

 

Select the required type to load into the project. 
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In Ribbon, click “Structure” ➜ draw walling by dragging starting point to end 

In the Properties panel, select the corresponding type and dimension of walling 
➜ fill in “mark” for identification of element ➜Fill in “ELS_Phase” to identify the 
phasing (i.e. 1,2,3,4 …etc) 

Set cross-section rotation if necessary 
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4.4.3 Create Strut / Short Strut / Tie 

In Ribbon, click “Structure”  ➜ click “BEAM” ➜ drag from starting point to end to 
create the strut / tie     /short strut 

In the Properties panel, select the  corresponding type and dimension  ➜  select 
the reference level ➜   Fill  in “Mark” for identification of element ➜ Fill in 
“ELS_Phase” to identify the phasing (i.e. 1,2,3,4 …etc.) 
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Repeat the above steps 
 

 
 

Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Structural 
Framing 

ANN-FTG-CIC-
Rectangular 

Standard 

Structural Column ANN-SCG-CIC Mark 

 
 
 
 

4.4.4 Create Stage Topo / Final Topo 

In Ribbon, click “Massing & Site” ➜ click “Toposurface” ➜ Input surface 
“Elevation” ➜ click “Place Point” on specific elevation ➜ click “Tick” ➜ Repeat 
above steps for different elevations 
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In the Properties panel, fill in “ELS_Phase” and “Name” to identify the phasing 
(i.e. 1,2,3,4 …etc.) and the name of the toposurface (i.e. 1,2,3,4 …etc.). Select 
“Earth” for Material. 

For final excavation toposurface, fill in “Final” for Name and select “Final 
Excavation Level” for Material. 
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Add Symbol in plan view (Refer to section 7.1.4 Add annotation symbol) 
 

Category Family Type 

Generic 
Annotation 

ANN-GNN-CIC-Cut_Slope 5mm 

10mm 

 

Add spot elevation for final excavation in plan view 

In ribbon ➜ click “Annotate” ➜ “Spot Elevation” ➜ select “SPE-AEC-
Final_Excavation_Level_Prefix” in properties panel ➜ place to the desired 
location. 

 
4.5 Ground Investigation 

The following objects will be modelled: 

  Bored Hole 

  Standard penetration tests result 

  Profile for inferred boundaries of different geological strata 

  Instrument checkpoints 
 

4.5.1 Insert Bored Hole using Dynamo 

Prepare the bored hole coordination table in excel format for dynamo input. 
Basic information shall be input by the user: 

  Bored hole number 

  Soil / rock layer 

  Easting coordination 
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  Northing coordination 

  Layer top-level (mPD) 

  Layer bottom level (mPD) 
 

Click “Manage” in ribbon ➜ click “Dynamo” 

(Remark: User may download Dynamo from the below website: 
https://dynamobim.org/download/) 

 

Open dynamo user interface in window ➜ Open dynamo file 
“bh_gen(v1.3.4).dyn” 
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Click to edit “File Path” ➜ Choose the corresponding excel file of the bored hole 
coordination table. 

 

Edit “Family Type” in Dynamo window ➜ change the type to “STE-OTR-CIC-
Borehole: STE-OTR-CIC- Borehole” 

 
Click “Run” in Dynamo window 

 

Close the Dynamo window ➜ present bored hole elements in Revit screen 
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4.5.2 Insert Standard penetration test result using Dynamo 

Prepare a standard penetration test point table in excel format for dynamo input.  
Basic information shall  be input by user: 

  Count 

  Easting 

  Northing 

  Position Z 

  Value 
 

Click “Manage” in ribbon ➜ click “Dynamo” again for standard penetration test 
(SPT) input 

 

Open dynamo user interface in window ➜ Open dynamo file 
“spt_gen(v1.3.4).dyn” Click to edit “File Path” ➜ Choose the corresponding 
excel file 

Edit “Family Type” in  Dynamo  window  ➜  change  the  family  type  to “STE-
OTR-CIC-Borehole_SPT: STE-OTR-CIC-Borehole_SPT” 
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Click “Run” in Dynamo window 

 

Close the Dynamo window ➜ present SPT elements in Revit screen Select a 
bored hole ➜ edit the rockhead level manually. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Important Note: 

In the properties panel, “soil layer”, “Diameter”, “Base Elevation”, “Easting”, 
“Northing”, “Rock Head Level”, “Mark” are automatically generated by Dynamo 
input from previous steps. 

Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by 
Category) 

 

Category Family Type 

Site ANN-STG-CIC-Boredhole Elevation – Layer 

Elevation – Mark 

Elevation - N Value 

Plan – Down 

Plan - Up 
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4.5.3 Create rockhead profile 

In Ribbon, click “Insert” ➜ click “Import CAD” ➜ select the rockhead CAD file 
 

Make sure to unclick “Current view only” ➜ place the CAD file to the desired 
location. 

 

 

In Ribbon, click “Massing & Site” ➜ click “Toposurface” 
 

Click “Select Import Instance” ➜ select the imported rockhead CAD file 
 

Select the layer(s) that contains the elevation points of the profile ➜ click “OK” to 
generate the toposurface. 
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In properties panel, fill in “BH Rock” for Name. 

 

 
 
 

4.5.4 Create profile for inferred boundaries of different geological strata 

Select “BOREDHOLE” plan under Floor Plans in Project Browser. In Ribbon, 
click “Insert” ➜ click 

Open a site plan in Revit ➜ click “Massing & Site” in ribbon ➜ click 
“Toposurface” under Model Site. 
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Place point and set the elevation on the Toposurface according to the inferred 
boundaries for each bored hole ➜ click “Tick”. 
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In the properties panel, fill in the name of each boundary (ie. BH MD, BH ALLU, 
BH CDG, etc.) in “Name” 

 
4.5.5 Create Instrument check point 

The followings instrument check point object will be modelled: 

  Building settlement marker 

  Building Tilting check point with vertical displacement 

  Ground settlement check point 

  Utility settlement monitoring point on ground 

  Vibration check point 

  Observation Well 

  Pump Well 

  Recharge Well 

  Standpipe with piezometer 

Select “MONITORING CHECK POINT” plan under Floor  Plans in Project  
Browser.  In Ribbon, click “Massing & Site” ➜ click “Site Component” 

 
Select the specific types of instrument marker in the properties panel. 
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Place the object to the designed location. 

 
In the properties panel, fill in “Name” for identification of element. Select 
Up/Down/Left/Right for the display location of the name. 
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4.6 Site Formation 
The following objects will be modelled for site formation plan: 

  Site formation profile 

  Site drainage 

  Retaining wall 

  Soil nail 

 
4.6.1 Create Site formation profile 

Open a “SITE FORMATION” plan under Floor Plans in Project Browser ➜ click 
“Massing & Site” in ribbon ➜ click “Toposurface” under Model Site. 

Place point and set the elevation on the Toposurface to create ➜ click “Tick”. 
 

 
 

Repeat the above steps for a different stage of site profile. 

In the properties panel, fill in “SF” for Name for identification of element. 
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Add Symbol in plan view (Refer to section 7.1.4 Add annotation symbol) 
 

Category Family Type 

Detail Item DTL-OTR-CIC-Slope_Label Soil Cut Slope 

Soil Fill Slope 

Rock Cut Slope 

Rock Fill Slope 

 

Add Spot slope in plan view 

In ribbon ➜ click “Annotate” ➜ “Spot Slope” ➜ select “Sloped Toposurface” in 
properties panel ➜ place to the desired slope. 
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4.6.2 Create Site drainage 

Open “SITE FORMATION” plan under Floor  Plans in Project  Browser. In 
Ribbon, click “Massing & Site” ➜ click “Site Component” 

 
Select “STE-STU-CIC-Step_Channel” or “STE-STU-CIC-U_Channel” in the 
properties panel. 

Click “Place on Work Plane” ➜ Drag from starting point to end to create the 
channel. 

 

 

Channel sizes can be adjusted by clicking “Edit Type” in the properties panel. 
“Type Comments” define the text showing on the plan view. 
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4.6.3 Create Retaining wall 

Open “SITE FORMATION” under Floor Plans in Project Browser ➜ Click 
“Structure” in ribbon ➜“Model” ➜ ”Component” ➜ click “Model In-Place” 

 

Select “Site” in the Family Category and Parameters dialogue and fill in the 
name of retaining wall. Draw the retaining wall by using “Forms” tools. 
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4.6.4 Create Soil nail 

Open “Site Formation 3D” under 3D Views in Project Browser. In Ribbon, click 
“Massing & Site” ➜ click “Site Component” 

 
Select “STE-OTH-CIC-Soil_Nail” in the properties panel. 

 

Place it to the designed location along the surface of the toposurface. 
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In the properties panel, fill in “Name” for identification of element. 

 

 
 

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Site ANN-STG-CIC-Soil_Nail Up 

Down 

 

 
 
 

4.7 Drainage 
The following objects will be modelled for drainage plan: 

  Drainage pipe 

  Drain 

  Sanitary fitment 

  Manhole / Sump Pit / Gully / Trap / Petrol Interceptor 
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4.7.1 Create Drainage pipe 

In Ribbon, click “System” ➜ click “Pipe” under “Plumbing & Piping” 
 

Select the specific system type in the properties panel. 

 

In the properties panel, specific the System Type of the pipe. 
 

Under ribbon panel, select pipe diameter and offset from level. 
 

Specific the slope value for the sloped pipe. 
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Drag from starting point to end to create the pipe. 

 

 
Add slope symbol to the sloped pipe 

In ribbon  ➜ click  “Annotate”  ➜ “Spot  Slope”  ➜ select  “Pipe Direction” in 
properties  panel  ➜ place to the desired pipe. 

In the properties panel, fill in 0mm to “Offset from Reference”. 
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4.7.2 Create Drain 

In Ribbon, click “System” ➜ click “Plumbing Fixture” under “Plumbing & Piping” 
 

Select the specific drain type in the properties panel. 
 

Place it to the designed location. 
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Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 

 

Category Family Type 

Plumbing Fixture ANN-PMG-CIC Type Mark (RWP) 

Type Mark (WP) 

 
 

4.7.3 Create Sanitary fitment 

In Ribbon, click “System” ➜ click “Plumbing Fixture” under “Plumbing & Piping” 
 

Select the specific sanitary fitment item in properties panel ➜Place it to the 
designed location 
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4.7.4 Create Manhole / Sump Pit / Gully / Trap / Petrol Interceptor 

In Ribbon, click “System” ➜ click “Plumbing Fixture” under “Plumbing & Piping” 
 

Select the specific item in properties panel ➜Place it to the designed location 

 

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Family Type 

Plumbing 
Fixture 

ANN-PMG-CIC Detail 

(RWP) 

Detail 

(SWP) 

Detail (WP) 
 
 

4.8 Curtain Wall 
The following objects will be modelled for curtain wall plan: 

  Embed 

  Mullion and transom 

  Glass panel and louvre 
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4.8.1 Create Embed 

In Ribbon, click “Structure” ➜ click “Component” under “Model” 
 

Select the specific item in properties panel ➜Place it to the designed location 
 

 
4.8.2 Create mullion and transom 

Create Curtain wall by clicking “Architecture” ➜ “Wall” ➜ select “Curtain Wall” in 
the properties panel 

 

Create curtain grid by clicking “Architecture” ➜ “Build” ➜“Curtain Grid” 

 
 

 

Add mullion by clicking “Architecture” ➜ “Build” ➜“Mullion” ➜Select the 
specific type of mullion in properties➜ Place it to the designed curtain grid 
location 



86  

 

 
4.8.3 Create glass panel / louvre 

For each panel inside, select the type of curtain wall panel in properties. 
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5 Configuring Schedules 
 

5.1 Superstructure 
 

5.1.1 Column Schedule 

Click “COLUMN SCHEDULE” in Schedules/Quantities (all) of Project Browser. 
 

 

Auto generated 
field 

COLUMN MARK, SIZE 

Manually Input field / 

 
 

5.1.2 Tower Floor Level Schedule 

Click “TOWER FLOOR LEVEL” in Schedules/Quantities (all) of Project Browser. 
 

 

Auto generated 
field 

LEVEL, S.F.L. 

Manually Input field / 

 
 

5.1.3 Wall RC Schedule 

Click “R.C. WALL SCHEDULE” in Schedules/Quantities (all) of Project Browser. 
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Auto generated 
field 

FLOOR, WALL MARK, THICKNESS 

Manually Input field CONCRETE GRADE, VERTICAL BARS, HORIZONTAL BARS, BINDER 
(HORIZONTAL), BINDER(VERTICAL), STEEL RATIO 

 
 

5.1.4 Beam RC Schedule 

Click “R.C. BEAM SCHEDULE” in Schedules/Quantities (all) of Project Browser. 

 

 
 

Auto generated 
field 

BEAM MARK, BEAM SIZE 

Manually Input field ELEV. REFER, REINFORCEMENT (a-g), REINFORCEMENT (Links 1-
3), DIMENSION (A-D) 
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5.2 Foundation 
 

5.2.1 Bored Pile Loading Schedule 

Click “BORED PILE LOADING SCHEDULE” in Schedules/Quantities (all) of 
Project Browser. 

 

 
 

 
 

Auto generated 
field 

BORED PILE MARK, BORED PILE DIAMETER, PILE BASE 
DIAMETER, CUT-OFF LEVEL, TENTATIVE FOUNDING LEVEL 

Manually Input field BORED PILE CAP THICKNESS, BORED PILE EFFECTIVE SHAFT 
DIAMETER, ROCK SOCKET DIAMETER, BELLOUT DEPTH, TENTATIVE 
ROCKHEAD LEVEL, TENTATIVE PILE LENGTH, EFFECTIVE ROCK 
SOCKET LENGTH, SELF-WEIGHT OF BORED PILE (SUBMERGED) 
(SWP), Dmin (total), SDL(total), LIVE LOAD (LL) (total), Wmax 
(total), TOTAL UPLIFT FORCE DUE TO GROUND WATER (U), 
ADDITIONAL LOAD DUE TO STEPPING EFFECT, VERTICAL 
BARS, LINKS, PILE BARING CAPACITY (COMPRESSION), 
ROCK FRICTION (COMPRESSION), ROCK FRICTION 
(TENSION), ROCK/SOIL MASS (SUBMERGED), REFERENCE 
BORED HOLE 
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5.2.2 Socket H-Pile Loading Schedule 

Click “SOCKET H-PILE LOADING SCHEDULE” in Schedules/Quantities (all) of 
Project Browser. 

 
 

 
 

 

Auto generated 
field 

PILE MARK, CUT-OFF LEVEL, TENTATIVE ROCKHEAD LEVEL, 
TENTATIVE FOUNDING LEVEL 

Manually Input field PILE CAP THICKNESS, NUMBER OF PILES PER CAP, TENTATIVE 
PILE LENGTH, EFFECTIVE ROCK SOCKET LENGTH, Dmin, SDL, 
LIVE LOAD (LL), Wmax, UPLIFT FORCE DUE TO GROUND WATER 
(U), SELF- WEIGHT (SUBMERGED) (SWP), ADDITIONAL LOAD DUE 
TO STEPPING EFFECT, COMPRESSION CAPACITY (PER PILE), 
TENSION CAPACITY (TENSION), ROCK/SOIL MASS (SUBMERGED) 
(PER PILE), REFERENCE BORED HOLE 

 
 

5.2.3 Column Loading Schedule above Pile Cap 

Click “COLUMN LOADING SCHEDULE ABOVE PILE CAP” in 
Schedules/Quantities (all) of Project Browser. 



91  

 
 

 
 

 

 

Auto generated 
field 

COLUMN MARK, DEAD LOAD (DL), DL + LL, 

Manually Input field ANGLE, MIN DEAD LOAD (Dmin), SDL, LIVE LOAD (LL), W0, W90, WU, 
WV, WMAX 

 
 

5.2.4 Wall Loading Schedule above Pile Cap 

Click “WALL LOADING SCHEDULE ABOVE PILE CAP” in Schedules/Quantities 
(all) of  Project Browser. 

 

 

 

 

Auto generated 
field 

WALL MARK, DEAD LOAD (DL), DL + LL, 

Manually Input field ANGLE, MIN DEAD LOAD (Dmin), SDL, LIVE LOAD (LL), W0, W90, WU, 
WV, WMAX 
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5.2.5 Tie Beam R.C. Details Schedule 

Click “TIE BEAM R.C. DETAILS SCHEDULE” in Schedules/Quantities (all) of 
Project Browser. 

 

 

 
Auto generated 
field 

TIE BEAM MARK, BEAM SIZE, LENGTH, TIE BEAM TOP LEVEL, TOP 
LEVEL (Lv1), TOP LEVEL (Lv2), 

Manually Input field PILE CAP (P1), PILE CAP (P2), STEEL BAR, LINK, SECTION 
REFERENCE, ELEVATION REFERENCE 

 
 
 
 

5.2.6 Ground Investigation Table of Rock Head 

Click “GROUND INVESTIGATION TALBE OF ROCK HEAD” in 
Schedules/Quantities (all) of Project Browser. 

 
Auto generated 
field 

DRILL HOLE MARK 

Manually Input field ROCKHEAD LEVEL 

 
 

5.3 Excavation and Lateral Support 
 

5.3.1 Schedule of Horizontal Tie 

Click “SCHEDULE OF HORIZONTAL TIE” in Schedules/Quantities (all) of 
Project Browser. 
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Auto generated 
field 

ITEM, GRADE, MEMBER SIZE 

Manually Input field MEMBER MARK 

 
 

5.3.2 Schedule of Main Strut 

Click “SCHEDULE OF MAIN STRUT” in Schedules/Quantities (all) of Project 
Browser. 

 
 

Auto generated 
field 

WALING MEMBER SIZE, 

Manually Input field PILE TYPE, LAYER, PRELOAD, PRELOAD PER STRUT, 
HORIZONTAL LOAD, DESIGN LOAD FOR STRUT 

 
 
 

5.3.3 Schedule of Secondary Strut and Corner Strut 

Click “SCHEDULE OF SECONDARY STRUT AND CORNER STRUT” in 
Schedules/Quantities (all) of Project Browser. 

 

Auto generated 
field 

STRUT LEVEL, WALING MEMBER SIZE 

Manually Input field PILE TYPE, LAYER 

 
 
 

5.3.4 Schedule of Vertical Tie 

Click “SCHEDULE OF VERTICAL TIE” in Schedules/Quantities (all) of Project 
Browser. 

 

 

Auto generated 
field 

ITEM, GRADE, MEMBER SIZE 

Manually Input field MEMBER MARK 

 
 
 

5.3.5 Schedule of Wailing 

Click “SCHEDULE OF WAILING” in Schedules/Quantities (all) of Project 
Browser. 
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Auto generated 
field 

WALING MEMBER SIZE 

Manually Input field PILE TYPE, LAYER, COMPRESSION, SHEAR, MOMENT 

 
 

5.3.6 Section Properties of Horizontal Tie 

Click “SECTION PROPERTIES OF HORIZONTAL TIE” in Schedules/Quantities 
(all) of Project Browser. 

 

Auto generated 
field 

ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, 
SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE 
THICKNESS T 

Manually Input field / 

 
 
 

5.3.7 Section Properties of Short Strut/ Spacer 

Click “SECTION PROPERTIES OF SHORT STRUT / SPACER” in 
Schedules/Quantities (all) of Project Browser. 

 

Auto generated 
field 

ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, 
SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE 
THICKNESS T 

Manually Input field / 

 
 
 

5.3.8 Section Properties of Struts 

Click “SECTION PROPERTIES OF STRUTS” in Schedules/Quantities (all) of 
Project Browser. 
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Auto generated 
field 

ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, 
SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE 
THICKNESS T 

Manually Input field / 

 
 

5.3.9 Section Properties of Vertical Tie 

Click “SECTION PROPERTIES OF VERTICAL TIE” in Schedules/Quantities (all) 
of Project Browser. 

 
 

Auto generated 
field 

ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, 
SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE 
THICKNESS T 

Manually Input field / 

 
 
 

5.3.10 Section Properties of Wailing 

Click “SECTION PROPERTIES OF WAILING” in Schedules/Quantities (all) of 
Project Browser. 

 

 

Auto generated 
field 

ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, 
SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE 
THICKNESS T 

Manually Input field / 

 
 
 

5.3.11 Sheet Pile Schedule 

Click “SHEET PILE SCHEDULE” in Schedules/Quantities (all) of Project 
Browser. 
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Auto generated 
field 

MEMBER SIZE, TOE LEVEL 

Manually Input field SHEET PILE TYPE, MAX RETAINING HEIGHT, MIN EMBEDMENT 
LENGTH, FINAL EXCAVATION LEVEL, GRADE 

 
 

5.3.12 Sheet Pile Section Properties 

Click “SHEET PILE SECTION PROPERTIES” in Schedules/Quantities (all) of 
Project Browser. 

 

 

Auto generated 
field 

DIMENSIONS, SECTION AREA (PER PILE), MOMENT OF INERTIA 
(PER PILE), WEIGHT (PER PILE), SECTION MODULUS (PER PILE), 
SECTION AREA (PER 1m PILE), MOMENT OF INERTIA (PER 1m 
PILE), WEIGHT (PER 1m PILE), SECTION MODULUS (PER 1m PILE) 

Manually Input field MEMBER SIZE 

 
 
 

5.3.13 Instrument Schedule 

Click “INSTRUMENT SCHEDULE” in Schedules/Quantities (all) of Project 
Browser. 

 
 

Auto generated 
field 

TYPE 

Manually Input field SYMBOL, NUMBER 
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5.4 Drainage 
 

5.4.1 Strom Water Manhole Schedule 
 

 
Auto generated 
field 

DEPTH 

Manually Input field MANHOLE NO., PIPE DIAMETER, C.L., I.L., D.T.I.L., TYPE 

 
5.4.2 Foul Water Manhole Schedule 

 

 

Auto generated 
field 

DEPTH 

Manually Input field MANHOLE NO., PIPE DIAMETER, C.L., I.L., D.T.I.L., TYPE 

 
5.4.3 Petrol Interceptor Schedule 

 

 

Auto generated 
field 

DEPTH 

Manually Input field PETROL INTERCEPTOR NO., C.L., I.L., B.L. 

 
5.4.4 Sump Pit Schedule 

 

 

Auto generated 
field 

SUMP PIT SIZE 

Manually Input field SUMP PIT NO., C.L., I.L., B.L., PUMP NO., PUMP DUTY 
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6 Standardising View Setting 
This template has defined the desired settings. The users can use view 
templates to manage these settings by applying the view template, user 
efficiency on projects enhanced by assigning default view template for each view 
type. The standardised view properties include, but not limited to, view scale, 
detail level, model display setting. 

 

Open either view plan ➜ On the “View” tab ➜ find the “Graphics” panel ➜ select 
“View Templates” ➜select “Apply Template Properties to Current View” 

 

 

In “View Templates” dialogue box ➜ on the right, select the view template 
applied to the corresponding view ➜ click “OK” to close the window. 

Changes to view templates are automatically reflected in the views to which they 
have been assigned. 
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6.1 Superstructure 
The following view templates can be applied into view: 

 

View Type View template 
name 

Plans CIC_Block Plan CIC_Structural Framing Plan 

CIC_Column RC Detail CIC_Wall RC Detail 

CIC_Slab RC Detail CIC_Water Tank Layout Plan 

CIC_Structural Loading Key Plan CIC_Stairs Layout 

Plan CIC_Water Tank Layout Plan 

Sections / 
Elevations 

CIC_Beam RC Detail CIC_Stairs RC Detail 

CIC_Water Tank Section View 

3D Views CIC_Structural 3D 

 
 
 

6.2 Demolition including hoarding 
The following view templates can be applied into view: 

 

View Type View template 
name 

Plans CIC_Block Plan 

CIC_Demolition Plan 

CIC_Hoarding Layout Plan 

Sections / 
Elevations 

CIC_Hoarding Section View 

3D Views CIC_Structural 3D 

 
 

6.3 Foundation 
The following view templates can be applied into view: 

 

View Type View template 
name 

Plans CIC_Block Plan CIC_ Pile Cap RC Plan 

(Shear) CIC_Column/Wall Layout Plan CIC_Piling Layout Plan 

CIC_Loading Intensity Plan CIC_Pile Cap Layout Plan 

CIC_Pile Cap RC Plan (Rebar) CIC_Monitoring Plan (FDN) 

Sections / 
Elevations 

CIC_Pile Cap RC Section 

CIC_Piling Section View 

3D Views CIC_Structural 3D 
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6.4 Excavation and lateral support 
The following view templates can be applied into view: 

 

View Type View template 
name 

Plans CIC_Block Plan 

CIC_ELS Layout Plan 

CIC_Monitoring Plan (ELS) 

Sections / 
Elevations 

CIC_ELS Elevation 

View CIC_ELS Section 

View 

CIC_ELS Section View (SEQ) 
3D Views CIC_ELS 3D 

 
 

6.5 Site Formation 
The following view templates can be applied into view: 

  

View Type View template 
name 

Plans CIC_Block Plan 

CIC_Site Formation Layout Plan 

Sections / 
Elevations 

CIC_Site Formation Section View 

3D Views CIC_ Site Formation 3D 

 
 

6.6 Drainage 
The following view templates can be applied into view: 

 

View Type View template 
name 

Plans CIC_Drainage Layout Plan 

Sections / 
Elevations 

CIC_Drainage Schematic Diagram 

3D Views / 

 
 

6.7 Curtain Wall 
The following view templates can be applied into view: 

 

View Type View template 
name 

Plans CIC_Curtain Wall Cast-in Layout Plan 

CIC_Curtain Wall Location Plan 

CIC_Embed Plan View 

Sections / 
Elevations 

CIC_Curtain Wall Cast-in Section View 
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 CIC_Curtain Wall Elevation 

CIC_Curtain Wall Section View 

CIC_Embed Section View 
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7 Preparing Drawing Production 
 

7.1 Duplicating Views 
For drawing production, the users may duplicate the view for further editing 
instead of the working view. 

Select a structural plan  ➜ right click ➜ click “Duplicate View” ➜ “Duplicate” ➜ 
re-naming the sheet to “DEMOLITION PLAN – EXISTING FRAMING PLAN” or 
re-naming by your own. 

 
 
 

7.1.1 Add Tags (Tag All not tagged) 

Click “Annotation” in ribbon ➜ click “Tag All” for column and beam marks. 
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Click both “Structural Column Tags” and “Structural Framing Tags” in below 
Window ➜ click “OK”. 

 

Choose “ANN-FTG-CIC-Rectangular” or “ANN-SCG-CIC” for the standard 
markings of beam and column respectively. 
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7.1.2 Add Tags (Tag by Category) 

Click “Annotation” in ribbon ➜ click “Tag by Category” for column and beam 
marks. 

 

Click “Tags..” in Option bar. 

 

Assign the required tag family and type to each category and click “OK”. 

 

Click the desired object to tag. 
 

7.1.3 Add Dimensions 

Create the grid dimension from “Aligned” under Dimension in Ribbon. 
 

 

Choose “CIC_2.5_Con_Diagonal” under Linear Dimension Style family for the 
standard style of dimension. 
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7.1.4 Add Annotation Symbols 

Click “Annotation” in ribbon ➜ click “Symbol” to place annotation symbols. 
 

 

Select the specific type of symbol from “Properties”. 

 
 

Place it to desired location. 
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7.2 Create Drafting View 

Despite creating 3D objects, 2D information can also be drafted in the drafting 
view when appropriate. For example, general notes and typical details. 

Click “Drafting View” under Create in View ➜ Re-naming the drafting view to 
“GENERAL NOTES FOR DEMOLITION” or by your own for easy reference. 

 
7.2.1 Text Note 

Insert text from the annotation. 

 
In the properties panel, choose the specific type of text. 
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7.2.2 Typical Details 

Create detail line / region. 

 

 
Create lines and choose different Line Style. 

 

Drafting the region by drawing tools. 
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Examples of Detail for Demolition Works: 

 
  



109  

7.3 Create Legend 

Click “View” in ribbon ➜ click “Legends” to create a new legend view. 
 

Use Annotation tool such as text, filled region and symbols to create the 
components in legends. 

 
 

Example of legends that already created in the Structural template. 

 
 

7.4 Create Drainage Schematic Diagram 
 

7.4.1 Create Elevation View 

Create an exterior elevation view in plan ➜adjust the width and length of the 
crop region 
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7.4.2 Add Tags to non-pipework drainage object 

Add Tag in elevation view (Refer to section 7.1.2 Add Tags – Tag by Category) 
 

Category Tag family Drainage object 

Plumbin
g Fixture 

ANN-PMG-CIC-Schem-Floor_Drain 

ANN-PMG-CIC-Schem-

Vertical_Floor_Drain ANN-PMG-CIC-

Schem-Water_Closet 

Floor_Drain 

Vertical_Floor_Drain 

Water_Closet 

 

Drag the tags to the location manually. 

 
 

7.4.3 Add detail item to routing of pipes 

Click “Annotation” in ribbon ➜ click “Component” in “Detail” to place detail item. 
 

 

In “Properties”, select “CIC_Pipe Line” ➜select the specific type of line 
 

Family Type Graphic
s 

CIC_Pipe Line DR-Waste 

DR-Waste with 

arrow DR-Waste 

with radius 
 

CIC_Pump Symbol WP 
 

CIC_Room Boundary F. LAV  
CIC_Sunken D1800 
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7.4.4 Apply view template 

Apply view template “CIC_Drainage Schematic Diagram” to the view. (Refer to 
section 6 Standardising View Setting) 

  



112  

8 Creating Sheet 
 

8.1 Sheet List 
Using a template sheet, the users can create a tabular view of sheets in a 
project. From “View” tab in ribbon ➜ click “Schedule” ➜ click “Sheet List”. 

In the field tab of the sheet list, add the field name sheet number, sheet name, 
sheet issue date and sheet revision to the list of scheduled fields. 

To begin adding sheets to the sheet list, go to the row panel in ribbon ➜ click 
“Insert” ➜ click “Data Rows”. The users can continue populating the schedule in 
this way. 

 
8.1.1 Superstructure 

For superstructure submission, this template shows the following examples for 
your reference. 

 

Sheet Number Sheet Name 

S001 GENERAL NOTES FOR SUPERSTRUCTURE 

S002 TYPICAL FLOOR FRAMING PLAN 

S003 BEAM R.C. SCHEDULE 

S004 BEAM R.C. DETAIL (SCHEDULE VERSION) 

S005 BEAM R.C. DETAIL 

S006 COLUMN R.C. DETAIL 

S007 WALL R.C. DETAIL (1 OF 2) 

S007A WALL R.C. DETAIL (Schedule) 

S008 WALL R.C. DETAIL (2 OF 2) 
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S009 SLAB R.C. DETAIL 

S010 STAIRCASE R.C. DETAIL 

S011 WATER TANK R.C. DETAIL 

 
 

8.1.2 Demolition including hoarding 

For Demolition submission, this template shows the following examples for your 
reference. 

 

Sheet Number Sheet Name 

D001 GENERAL NOTES FOR DEMOLITION 

D002 DEMOLITION PLAN – EXISTING G/F, 1/F FRAMING PLAN 

D003 DEMOLITION DETAILS (BY HAND HELD TOOLS) 

D004 DETAIL FOR DEMOLITION WORKS (1/2) 

D005 DETAIL FOR DEMOLITION WORKS (2/2) 

H001 HOARDING LAYOUT PLAN 

H002 HOARDING TYPICAL DETAIL 

 
 

8.1.3 Foundation 

For Foundation submission, this template shows the following examples for your 
reference. 

 

Sheet Number Sheet Name 

P001 GENERAL NOTES FOR FOUNDATION 

P002 PILING LAYOUT PLAN 

P003 PILING SECTION A & SECTION B 

P004 PILING SECTION C 

P005 COLUMN / WALL LOADING PLAN 

P006 COLUMN / WALL LOADING SCHEDULE 

P007 LOADING INTENSITY PLAN 

P008 PILE LOAD SCHEDULE 

P009 MONITORING PLAN 

P010 PILE CAP REINFORCEMENT LAYOUT PLAN 

P010A PILE CAP REINFORCEMENT LAYOUT PLAN (2 OF 2) 

P011 COLUMN AND WALL STARTER DETAILS 

P012 TIE BEAM DETAILS & SCHEDULE 

P013 PILE CAP LAYOUT PLAN 

P014 GENERAL NOTES FOR PILE CAP 
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8.1.4 Excavation and Lateral Support 

For Excavation and lateral support submission, this template shows the following 
examples for your reference. 

 

Sheet Number Sheet Name 

E001 EXCAVATION & LATERAL SUPPORT GENERAL NOTES 

E002 EXCAVATION & LATERAL SUPPORT LAYOUT PLAN 

E003 EXCAVATION & LATERAL SUPPORT SECTIONS (1 OF 2) 

E004 EXCAVATION & LATERAL SUPPORT SECTIONS (2 OF 2) 

E005 EXCAVATION & LATERAL SUPPORT CONSTRUCTION 
SEQUENCE (1 OF 2) 

E006 EXCAVATION & LATERAL SUPPORT CONSTRUCTION 
SEQUENCE (2 OF 2) 

E007 EXCAVATION & LATERAL SUPPORT ELEVATION 

E008 EXCAVATION & LATERAL SUPPORT WORKS MONITORING PLAN 

E009 EXCAVATION & LATERAL SUPPORT WORKS PUMPING TEST 
SETTING OUT PLAN 

 
 

8.1.5 Ground Investigation 

For Ground Investigation submission, this template shows the following 
examples for your reference. 

 

Sheet Number Sheet Name 

/ / 

 
 

8.1.6 Site Formation 

For Site Formation submission, this template shows the following examples for 
your reference. 

 

Sheet Number Sheet Name 

T001 GENERAL NOTES FOR SITE FORMATION 

T002 SITE FORMATION LAYOUT PLAN 

T003 SITE FORMATION SECTIONS 

 
 

8.1.7 Drainage 

For Site Formation submission, this template shows the following examples for 
your reference. 

 

Sheet Number Sheet Name 

M001 GENERAL NOTES FOR DRAINAGE 

M002 SCHEMATIC DIAGRAM OF DRAINAGE SYSTEM 

M003 DRAINAGE LAYOUT PLAN FOR TYPICAL FLOOR 
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M004 DRAINAGE INSTALLATION DETAILS 

M005 DRAINAGE SCHEDULES 

 

8.1.8 Curtain Wall 

For Site Formation submission, this template shows the following examples for 
your reference. 

 

Sheet Number Sheet Name 

C001 GENERAL NOTES FOR CURTAIN WALL 

C002 CURTAIN WALL LOCATION PLAN 

C003 CURTAIN WALL CAST-IN LAYOUT PLAN 

C004 DETAIL OF EMBED AND MEMBER SECTION PROPERTIES 

C005 CURTAIN WALL PARTIAL ELEVATIONS AND SECTIONS 
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8.2 Title Block 
The title block includes standardised view and location of BD’s approval stamp 
chop and RSE’s name chop. 
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8.3 Examples of sheets 
Examples of sheets can be found in Sheet (all) from the project browser. 

 

 
8.3.1 Superstructure 

 
8.3.1.1 General Notes 

From the project browser, click “S001 - GENERAL NOTES FOR 
SUPERSTRUCTURAL” in Sheet (all). The sheet consists of general notes and 
block plan, as basic components. 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

BLOCK PLAN 

Drafting view NOTES FOR SUPERSTRUCTURE 

 
 

8.3.1.2 Typical Floor Framing Plan 

From project browser, click “S002 - TYPICAL FLOOR FRAMING PLAN” in 
Sheet (all). The sheet consists of notes, legend, plans and schedules, as basic 
components. 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Structural 
Plan 

TYP FLOOR FRAMING PLAN 

TYP FLOOR LOADING KEY PLAN 

Drafting view LOADING KEY PLAN 

FRAMING PLAN NOTES 

Schedule COLUMN SCHEDULE 

TOWER FLOOR LEVEL 

Legend FRAMING PLAN LEGEND 

 
 

8.3.1.3 Beam R.C. Detail 

From the project browser, click “S003 – BEAM R.C. SCHEDULE” in Sheet (all). 
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Drag beam R.C. detail from drafting view into the sheet. 3 

Drag the following views to the sheet. 
 

View Type View 
Name 

Schedule R.C. BEAM SCHEDULE 

Drafting View BEAM RC DETAIL 

 
 

8.3.1.4 Beam R.C. Detail 

From project browser, click “S004 – BEAM R.C. DETAIL” in 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Section CTB1 SECTION 1, CTB1 SECTION A, CTB56 SECTION 1, 
CTB56 SECTION B, CTB56 SECTION C 

 
 

8.3.1.5 Column R.C. Detail 

From project browser, click “S005 – COLUMN R.C. DETAIL” in Sheet (all). 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

COLUMN REBAR PLAN (C1-C10) 

Drafting View COLUMN REBAR TABLE 

COLUMN CRITICAL ZONE 

COLUMN BEAM JOINT DETAIL 

 
  



121  

8.3.1.6 Wall R.C. Detail 

From the project browser, click “S006 – WALL R.C. DETAIL (1 OF 2)” in Sheet 
(all). 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Structural 
Plan 

5F WALL REBAR PLAN (WALL DETAIL 1-5) 

Legend WALL RC DETAIL LEGEND 

Schedule R.C. WALL SCHEDULE 

 
 

8.3.1.7 Wall R.C. Detail (Schedule) 

From project browser, click “S007 – WALL R.C. DETAIL (Schedule)” in Sheet 
(all). 

 



122  

Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

WALL DETAIL (SCHEDULE) 1 

WALL DETAIL (SCHEDULE) 2 

Drafting View WALL REBAR TABLE 

 
 

8.3.1.8 Slab R.C. Detail 

From project browser, click “S009 – SLAB R.C. DETAIL” in Sheet (all). 

 

Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

TYP FLOOR SLAB R.C. DETAILS 
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8.3.1.9 Staircase R.C. Detail 

From the project browser, click “S010 – STAIRCASE R.C. DETAIL” in Sheet 
(all). 

 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

ST1, ST2 

Section STAIRS RC DETAIL  (ST-01) 

STAIRS RC DETAIL  (ST-02) 

 
8.3.1.10 Water Tank R.C. Detail 

From the project browser, click “S011 – WATER TANK R.C. DETAIL” in Sheet 
(all). 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

2/F Water Tank 

Section WATER TANK SECTION 1 

WATER TANK SECTION 2 

 
8.3.2 Demolition including hoarding 

 
8.3.2.1 General Notes 

From the project browser, click “D001 - GENERAL NOTES FOR DEMOLITION” 
in Sheet (all). The sheet consists of general notes and title block, as basic 
components. 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Structural 
Plan 

BLOCK PLAN 

Drafting View GENERAL NOTES FOR DEMOLITION 

 
 

8.3.2.2 Demolition Plan – Existing G/F, 1/F Framing Plan 

From the project browser, click “D002 – DEMOLITION PLAN – EXISTING G/F, 
1/F FRAMING PLAN” in Sheet (all). 
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Drag the following views to the sheet. 

 

View Type View 
Name 

Structural 
Plan 

DEMOLITION PLAN - EXISTING G/F FRAMING PLAN 

DEMOLITION PLAN - EXISTING 1/F FRAMING PLAN 

Legend CIC_DEMOLITION PLAN 

 
 

8.3.2.3 Demolition Details (By Hand Held Tools) 

From the project browser, click “D003 – DEMOLITION DETAILS (BY HAND 
HELD TOOLS)” in Sheet (all). 
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Drag the following views to the sheet. 
View Type View 

Name 
Drafting View TYPICAL SEQUENCE OF TOP DOWN METHOD 

 
 

8.3.2.4 Details for Demolition works 

From the project browser, click “D004 – DETAIL FOR DEMOLITION WORKS” in 
Sheet (all). 

 

Drag the following views to the sheet. 
 

View Type View 
Name 

Drafting View DETAIL FOR DEMOLITION WORKS (1) 

DETAIL FOR DEMOLITION WORKS (2) 
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8.3.2.5 Hoarding Layout Plan 

From the project browser, click “H001 – HOARDING LAYOUT PLAN” in Sheet 
(all). 

 

Drag the following views to the sheet. 
 

View Type View 
Name 

Drafting View HOARDING PLAN 

Structural 
Plan 

HOARDING PLAN 

BLOCK PLAN 

Section HOARDING (TYPE C) SECTION A1 
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8.3.2.6 Hoarding Typical Detail 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Drafting View HOARDING TYPICAL DETAIL 

Section DETAIL 1-7 

ELEVATION OF COVERED WALKWAY & GANTRY 

SECTION A (GANTRY) 

TYPICAL SECTINON OF HOARDING TYPE A 
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8.3.3 Foundation 

 
8.3.3.1 General Notes 

From the project browser, click “P001 - GENERAL NOTES FOR FOUNDATION” 
in Sheet (all). 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Drafting View NOTES FOR FOUNDATION 

 
 

8.3.3.2 Piling Layout Plan 

From project browser, click “P002 – PILING LAYOUT PLAN” in Sheet (all). 

 

Drag the following views to the sheet. 
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View Type View 
Name 

Legend PILING LAYOUT PLAN 

Structural 
Plan 

PILING LAYOUT PLAN 

BLOCK PLAN 

 
 

8.3.3.3 Piling Section 

From project browser, click “P003 – Piling Section A & Section B” or “P004 – 
Piling Section C” in Sheet (all). 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Legend PILING SECTION 

Section PILING SECTION A-C 

 
 

8.3.3.4 Column/Wall Loading Plan 

From project browser, click “P005 – COLUMN / WALL LOADING PLAN” in 
Sheet (all). 

 

Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

COLUMN & WALL LAYOUT PLAN 

Drafting View COLUMN WALL LOADING NOTES 
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8.3.3.5 Column/Wall Loading Schedule 

From project browser, click “P006 – COLUMN / WALL LOADING SCHEDULE” 
in Sheet (all). 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Schedule COLUMN LOADING SCHEDULE ABOVE PILE CAP (1 OF 

2) COLUMN LOADING SCHEDULE ABOVE PILE CAP (2 

OF 2) WALL LOADING SCHEDULE ABOVE PILE CAP (1 

OF 2) 

WALL LOADING SCHEDULE ABOVE PILE CAP (2 OF 2) 
 
 

8.3.3.6 Loading Intensity Plan 

From project browser, click “P007 – LOADING INTENSITY PLAN” in Sheet (all). 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Structural 
Plan 

LOADING INTENSITY PLAN AT B2 

LOADING INTENSITY PLAN FOR FILL AT 

B2 

LOADING INTENSITY PLAN FOR UPTHRUST AT B2 
Legend LOADING INTENSITY 

 
 

8.3.3.7 Pile Load Schedule 

From project browser, click “P008 – PILE LOAD SCHEDULE” in Sheet (all). 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Schedule BORED PILE LOADING SCHEDULE (1 OF 2) 

BORED PILE LOADING SCHEDULE (2 OF 2) 

SOCKET H-PILE LOADING SCHEDULE (1 OF 

2) 

SOCKET H-PILE LOADING SCHEDULE (2 OF 2) 
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8.3.3.8 Foundation Monitoring Plan 

From project browser, click “P009 – FOUNDATION MONITORING PLAN” in 
Sheet (all). 

 
Drag the following views to the sheet. 
View Type View 

Name 
Structural 
Plan 

MONITORING PLAN (FDN) 

Legend MONITORING PLAN 

Drafting View NOTES FOR MONITORING PLAN 

Schedule INSTRUMENT SCHEDULE 

GROUND INVESTIGATION TALBE OF ROCK HEAD 
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8.3.3.9 Pile Cap Reinforcement Layout Plan 

From project browser, click “P010 – Pile Cap Reinforcement Layout Plan” in 
Sheet (all). 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Structural 
Plan 

PILE CAP REBAR PLAN - 

F1 PILE CAP SHEAR 

PLAN - F1 PILE CAP 

REBAR PLAN - F5 

PILE CAP SHEAR PLAN - F5 
Legend SHEAR LINK DIAGRAM (PILE CAP) 

Section SECTION A-D 
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8.3.3.10 Column and Wall Starter Details 

From project browser, click “P011 – Column and Wall Starter Details” in Sheet 
(all). 

 
Drag the following views to the sheet. 
View Type View 

Name 
Structural 
Plan 

PILE CAP COLUMN REBAR PLAN - PC1-TC10 

Legend STARTER BAR LEGEND 

Schedule WALL STARTER BAR SCHEDULE 

Drafting View STARTER BAR DETAIL 

STARTER BAR TABLE 
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8.3.3.11 Tie Beam Details and Schedule 

From project browser, click “P012 – Tie Beam Details & Schedule” in Sheet (all). 

 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Schedule TIE BEAM R.C. DETAILS SCHEDULE 

Drafting View TIE BEAM RC DETAIL 

 
 

8.3.3.12 Pile Cap Layout Plan 

From project browser, click “P013 – PILE CAP LAYOUT PLAN” in Sheet (all). 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Legend PILE CAPLAYOUT PLAN 

Structural 
Plan 

PILE CAP LAYOUT PLAN 

BLOCK PLAN 

 
 

8.3.3.13 General Notes for Pile Cap 

From project browser, click “P014 – GENERAL NOTES FOR PILE CAP” in 
Sheet (all). 

 

Drag the following views to the sheet. 
 

View Type View 
Name 

Drafting View NOTES FOR PILE CAP 
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8.3.4 Excavation and Lateral Support 

 
8.3.4.1 Excavation and Lateral Support General Notes 

From project browser, click “EXCAVATION & LATERAL SUPPORT GENERAL 
NOTES” in Sheet (all). 

 

Drag the following views to the sheet. 
 

View Type View 
Name 

Drafting View NOTES FOR ELS 

Schedule SCHEDULE OF HORIZONTAL TIE 

SCHEDULE OF MAIN STRUT 

SCHEDULE OF SECONDARY STRUT AND CORNER STRUT 

SCHEDULE OF VERTICAL TIE 

SCHEDULE OF WAILING 

SECTION PROPERTIES OF HORIZONTAL TIE 

SECTION PROPERTIES OF SHORT STRUT / 

SPACER SECTION PROPERTIES OF STRUTS 

SECTION PROPERTIES OF VERTICAL TIE 

SECTION PROPERTIES OF WAILING 

SOIL PARAMETER 
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8.3.4.2 Excavation and Lateral Support Layout Plan 

From the project browser, click “EXCAVATION & LATERAL SUPPORT 
LAYOUT PLAN” in Sheet (all). 

 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Legend ELS LAYOUT 

Structural 
Plan 

BLOCK PLAN 

ELS LAYOUT PLAN 

Schedule SHEET PILE SCHEDULE 

SHEET PILE SECTION PROPERTIES 

 
  



141  

8.3.4.3 Excavation and Lateral Support Sections 

From project browser, click “EXCAVATION & LATERAL SUPPORT SECTIONS 
(1 OF 2)” in Sheet (all). 

 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Legend ELS SECTION 

Section ELS SECTION A to ELS SECTION C 
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8.3.4.4 Excavation and Lateral Support Construction Sequence 

From the project browser, click “EXCAVATION & LATERAL SUPPORT 
CONSTRUCTION SEQUENCE (1 OF 2)” in Sheet (all). 

 
For different phase of construction sequence, it can be set from filter in this 
template. 

Select a section under the drawing ➜ in Ribbon, select “View” ➜ select 
“Visibility / Graphics” 
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In a window, select “Filter” ➜ For phase 0, unclick all filter under Visibility ➜ 
click “OK” 

 

For phase 1, click “ELS – Phase 1” and “Topo - Phase 1” under visibility ➜ click 
“OK” 

 

For final phase, select all “ELS – Phase 1 to 8” and both “Topo – Phase 8” and 
“Topo – Final” ➜ click “OK” 
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Drag the following views to the sheet. 

 

View Type View 
Name 

Drafting View ELS SEQUENCE 2 

Schedule SCHEDULE OF HORIZONTAL TIE 

Legend ELS SECTION 

Section ELS SEQUENCE SECTION (STAGE 0) to ELS SEQUENCE 
SECTION (STAGE 8) 

 
 

8.3.4.5 Excavation and Lateral Support Elevation 

From the project browser, click “EXCAVATION & LATERAL SUPPORT 
ELEVATION” in Sheet (all). 
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Drag the following views to the sheet. 
 

View Type View 
Name 

Elevation ELS ELEVATION A-B 

ELS ELEVATION B-C 

ELS ELEVATION C-

D 

ELS ELEVATION D-A 
 
 

8.3.4.6 Excavation and Lateral Support Monitoring Plan 

From the project browser, click “EXCAVATION & LATERAL SUPPORT WORKS 
MONITORING PLAN” in Sheet (all). 

 
Drag the following views to the sheet. 

 

View Type View 
Name 

Drafting View NOTES FOR ELS MONITORING 

Legend ELS MONITORING 

Structural 
Plan 

ELS MONITORING PLAN 

Schedule INSTRUMENT SCHEDULE 
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8.3.4.7 Excavation and Lateral Support Pumping test setting out Plan 

From the project browser, click “EXCAVATION & LATERAL SUPPORT WORKS 
PUMPING  TEST SETTING OUT PLAN” in Sheet (all). 

 
 

Drag the following views to the sheet. 
 

View Type View 
Name 

Drafting View NOTES FOR ELS PUMPING TEST 

Legend ELS MONITORING 

Structural 
Plan 

ELS PUMPING TEST SETTING OUT PLAN 

Legend INSTRUMENT SCHEDULE 

 
 

8.3.5 Site Formation 
 

8.3.5.1 General Notes 

From project browser 

  



147  

8.3.6 Drainage 
 

8.3.6.1 General Notes for Drainage 

From the project browser, click “GENERAL NOTES FOR DRAINAGE” in Sheet 
(all). 

 
 

View Type View 
Name 

Drafting View GENERAL NOTES 

 
8.3.6.2 Schematic Diagram of Drainage System 

From the project browser, click “SCHEMATIC DIAGRAM OF DRAINAGE 
SYSTEM” in Sheet (all). 

 
 

View Type View 
Name 

Elevation Drainage Schematic 
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8.3.6.3 Drainage Layout Plan for Typical Floor 

From the project browser, click “DRAINAGE LAYOUT PLAN FOR TYPICAL 
FLOOR” in Sheet (all). 

 

 

View Type View 
Name 

Floor Plans 6/F FLOOR PLAN 

3D View 3D View (Right), 3D View (Left) 

 
 

8.3.6.4 Drainage Installation Details 

From the project browser, click “DRAINAGE INSTALLATION DETAILS” in Sheet 
(all). 

 

View Type View 
Name 

Drafting View DRAINAGE INSTALLATION 
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8.3.6.5 Drainage Schedules 

From the project browser, click “DRAINAGE SCHEDULES” in Sheet (all). 
 

 

View Type View 
Name 

Schedule FOUL WATER MANHOLE SCHEDULE 

PETROL INTERCEPTOR SCHEDULE 

STORM WATER MANHOLE SCHEDULE 

SUMP PIT SCHEDULE 
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8.3.7 Curtain Wall 

 
8.3.7.1 Curtain Wall Layout Plan 

From the project browser, click “CURTAIN WALL LAYOUT PLAN” in Sheet (all). 

 
 

View Type View 
Name 

Floor Plan 5/F LAYOUT PART PLAN (FLAT B) 

 
8.3.7.2 Curtain Wall Case-in Layout Plan 

From the project browser, click “CURTAIN WALL CAST-IN LAYOUT PLAN” in 
Sheet (all). 

 

 

View Type View 
Name 

Floor Plan 5/F CAST-IN LAYOUT PLAN (FLAT B) 

Section CAST-IN SECTION 1, CAST-IN SECTION 2 
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8.3.7.3 Detail of Embed and Member Section Properties 

From project browser, click “DETAIL OF EMBED AND MEMBER SECTION  
PROPERTIES” in  Sheet (all). 

 

View Type View 
Name 

Floor Plan 5/F EMBED E2 LAYOUT PLAN 

Section EMBED (E2) SECTION 

 
8.3.7.4 Curtain Wall Partial Elevations and Sections 

From project browser, click “CURTAIN WALL PARTIAL ELEVATIONS AND 
SECTIONS” in Sheet (all). 

 

View Type View 
Name 

Elevation CURTAIN WALL ELEVATION 

Section CURTAIN WALL SECTION A 
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9 Exporting Models as Deliverables 
 

9.1 Exporting 3D models as NWC 
Publishing to 3D, the user can create a single 3D representation of the model 
that can be orbited, control visibility of element categories, and be queried for 
the properties of any of elements. 

Click “Add-ins” ➜ click “Naviswork” and setting ➜ click “OK” to publish a 3D 
model for sharing. 

 
9.2 Exporting 2D models as PDF 

Publishing to 2D can create either a single view or a whole collection of 
interconnected views and sheets packaged as one file. 

Click  “File”  ➜  click  “Print”  ➜ edit “Properties / File Location  / Print Range  / 
Settings”  ➜ click  “OK” to publish PDF. 
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Feedback Form 
 
CIC BIM User Guide for Preparation of Statutory Plan Submissions Revit 
December 2020 
 
To improve future editions of this publication, we would be grateful to have your comments.  
  
(Please put a "" in the appropriate box.) 
1. As a whole, I feel that the publication is:  Strongly  

  Agree 

Agree Neutral Disagree Strongly 

Disagree 

Informative      
Comprehensive      
Useful      
Practical      
2. Does the publication enable you to 

understand more about the subject? 
Yes No No Comment 

   
3. Have you made reference to the 

publication in your work? 
Quite Often Sometimes Never 

   
4. To what extent the publication benefits 

you? 
Strongly   

  Agree 

Agree Neutral Disagree Strongly 

Disagree 

Supply chain Information/data integrity      
Work efficiency      
Project Collaborations      
5. Overall, how would you rate our 

publication? 
Excellent Very Good Satisfactory     Fair     Poor 

     
6. Other comments and suggestions, please specify (use separate sheets if necessary). 
  
Personal Particulars (optional):* 
Name:   Mr. / Mrs./ Ms./ Dr./ Prof./ Ar. / Ir / Sr ^ 
Company:  
Tel:  
Address:  
E-mail: 
 

 
* The personal data in this form will be used only for this survey. Your data will be kept confidential 

and dealt with only by the Construction Industry Council. 
^ Circle as appropriate. 
  
Please return the feedback form to: 
CIC Secretariat – BIM 
E-mail:              bim@cic.hk; 
Address:           38/F, COS Center, 56 Tsun Yip Street, Kwun Tong, Hong Kong 
Fax No.: (852) 2100 9090 
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Preface



The Construction Industry Council (CIC) is committed to seeking continuous improvement in all aspects of the construction industry in Hong Kong. To achieve this aim, the CIC forms Committees, Task Forces and other forums to review specific areas of work with the intention of producing Alerts, Reference Materials, Guidelines and Codes of Conduct to assist participants in the industry to strive for excellence.

The CIC appreciates that some improvements and practices can be implemented immediately whilst others may take more time for implementation. It is for this reason that four separate categories of publication have been adopted, the purposes of which are as follows:



		Alerts

		The Alerts are reminders in the form of brief leaflets produced quickly to draw the immediate attention of relevant stakeholders to the need to follow some good practices or to implement some preventive measures in relation to the construction industry.





		Reference Materials

		The Reference Materials are standards or methodologies generally adopted and regarded by the industry as good practices. The CIC recommends the adoption of the Reference Materials by industry stakeholders where appropriate.





		Guidelines

		The Guidelines provide information and guidance on particular topics relevant to the construction industry. The CIC expects all industry stakeholders to adopt the recommendations set out in the Guidelines where applicable.





		Codes of Conduct

		The Codes of Conduct set out the principles that all relevant industry participants should follow. Under the Construction Industry Council (Cap 587), the CIC is tasked to formulate codes of conduct and enforce such codes. The CIC may take necessary actions to ensure compliance with the codes.







If you have read this publication, we encourage you to share your feedback with us. Please take a moment to fill out the Feedback Form attached to this publication in order that we can further enhance it for the benefit of all concerned. With our joint efforts, we believe our construction industry will develop further and will continue to prosper for years to come.






[bookmark: _Toc58920275]Foreword

I am glad to see the release of CIC BIM User Guide for Preparation of Statutory Plan Submissions Revit (December 2020). This software specific user guide shall be read in conjunction with the CIC BIM Standards for Preparation of Statutory Plan Submissions (December 2020). 

This software specific user guide is only provided to demonstrate the feasibility of drawings generation with the Standards. 

With the software specific user guides which contains step by step procedures of modelling, BIM users can easily apply the templates for the generation of statutory plan submission drawings.

Feedback on the CIC BIM User Guide for Preparation of Statutory Plan Submissions Revit (December 2020) from practitioners subsequent to the issuance of this publication will be considered in future revisions. 

On behalf of the CIC, I would like to thank everyone who has contributed to producing this CIC BIM User Guide for Preparation of Statutory Plan Submissions Revit (December 2020), in particular to the members of the Task Force on BIM Standards.



Ar. Ada FUNG, BBS

Chairperson 

Committee on Building Information Modelling

Construction Industry Council

December 2020
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1 [bookmark: _Toc59392360]Hardware / System Requirements



1.1 [bookmark: _Toc59392361]General





Hardware / system requirement for modellings, coordination and visualization visualisation on desktop/notebook computers and mobile devices should be determined by the BIM managers for different projects on a case by case basis. Minimum The minimum requirement varies for different applications, project sizes and operating systems.

https://www.autodesk.com/collections/architecture-engineering-construction/included- software






[bookmark: _Toc59392362]

2 [bookmark: _Toc59392363]Revit Basics



2.1 [bookmark: _Toc59392364]User Interface

· Open a project or family or create either one from a template to get started. The user interface provides the tools need to work in a model. The user interface can customize customise the interface to support the way for different works.

· Project Browser: organize organise the views, schedules, and sheets of the current project.

[image: ]
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· Properties palette: modify properties of select elements.

[image: ]

−	Ribbon: select the tools need to design the building model.

[image: ]

−		View Control Bar: provide options for changing the view display, including scale or visual style.



2.2 [bookmark: _Toc59392365]Difference of RVT, RTE, RFA files

It will eventually become necessary to save our work and share our progress with others in the model. RTEs are project template file. RVTs are working project files. Both files can be generated from Revit® projects. The difference between the files is that the template is used     to when you start a new project. You cannot be allowed to overwrite the template file, but you can be prompted for a new file name and location.

RFAs are family files that can either be loaded into a project or saved externally. Family template files are used to start a new family from family files of other projects.



[image: ]



2.3 [bookmark: _Toc59392366]Types of Family (system families, loadable families, in place family)

A group of elements with common parameters and graphical representation  called  family. There are three types of families in the model, including system families, loadable families and in in-place familiesy.

System Families

System families are  basic elements to  assembly on  a construction site. It  can be predefined  in the model, for example: wall, ceiling, beam and duct.

Loadable Families

Loadable families are families used to create non-standard or customiszed  components which can be purchased, delivered, and installed of buildings, such as windows, furniture, pump and chiller. It includes customiszation of annotation elements, such as symbols and title blocks.

In-Place Families

In-place elements are unique elements for a specific project. It can be created in-place geometry or import referredto other projects geometry to resize the shape.



2.4 [bookmark: _Toc59392367]Categories and Types

Category assigns the properties of a predefined family category to the component. The tool is only available within the Family Editor.

Types define components that apply across all types in that family.



2.5 [bookmark: _Toc59392368]Project base point, Grid, Levels and Work Planes

Project base point defines the origin (0,0,0) of the project coordinate system initially. Location of point can be determined by the team as a reference point. It can be used to establish a 



reference for measuring distances and positioning objects in relation to the model and used to position the building on site.

Grid line, annotation element, is a vertical plane. It helps to determine whether grid lines appear in each plan view that you create for a project. It can be added on the ribbon.

Level, annotation element, is a horizontal plane tol can act as a reference for level-based elements for story or reference plane within a building. In a section view or elevation view, it can add a level line in a model and create an associated plan view. It can be added on the ribbon.

Work plane defines a virtual 2-dimensional surface used as the origin for viewing or for sketching in the model. It can create on Architecture / Structure / System tab.



2.6 [bookmark: _Toc59392369]Suggested Model Nesting Method

When you import a model that contains a linked model, links become nested. Nested linked models can be shown or hided in the host model. The nested links display according to Reference Type setting in the host model.

1. Overlay -  unload  nested models into the host  model, do  not  display in the project

2. Attachment - load nested linked models in the host model, displays in the project









2.7 [bookmark: _Toc59392370]2D Views and Sheets

[image: ]2D views are oriented to specific coordinates such as plan, elevation and section.  Schedule  and details are another way of viewing information in neither 2D nor 3D. New A new view can be generated from the Create panel on View tab of theribbon ribbon.



Or you can right right-click a view name in Project browser and select one of the Duplicate View commends.



[image: ]



After creating a model in Revit, you can print the sheets by creating viewport for collecting documents. A sheet set consists of many sheets. Layout, elevation, section,  schematic, details, schedule, legend etc. can be included into the sheet set.



2.8 [bookmark: _Toc59392371]Tag, Symbols and Dimensions

[image: ]Tag is an annotation (text label) to identify elements in a drawing. Tag is intelligent, bi- directional graphics that report information stored in an object’s properties. Once you have tagged an element and entered a value in the tag, the tagged element will retain that value  until you remove it.



Symbol The symbol is a graphic representation of an annotation or other object.

[image: ]

Dimensions are used to convey the distance or angle between elements or part of elements. It is a bi-directional annotation that you can edit the distance directly within the dimension string to move elements a specific distance apart and updates automatically. There are permanent dimension and temporary dimension can be used in the model.



[image: ]



2.9 [bookmark: _Toc59392372]Different Parameters

[image: ]All contents in the model has have parameters, which are simply the information or data about the objects/ items.

Parameters that you create display in the Properties palette or Type Properties dialogue under the group you define and with the values you define.

Project Parameters - specific to a single project file and cannot share with other projects. They are added to elements by assigning them to multiple categories of elements, sheets, or views. It can be used for sorting, scheduling, and filtering.

Family Parameters - control variable values of the family, such as materials. It is specific to the family.

Shared Parameters - can be used in multiple families or projects. After you add a shared parameter definition to a family or project, you can use it as a family or project parameter. Because the definition of a shared parameter is stored in a separate file, it is protected from change. So, it can be tagged and scheduled.

Global Parameters - specific to a single project file but are not assigned to categories. It can be simple values, values derived from equations, or values taken from the model using other global parameters.






[bookmark: _Toc59392373]

[bookmark: _Toc59392374]

3 [bookmark: _Toc59392375]Getting Start

In this chapter, it covers how to configure and manage standards through the development and use of a project template. This template can be rich with information that goes beyond the out of box content that Revit provides. The template setting is established and content as well as explain how the reuse of work will increase productivity and standardisze with each project for Building Department submission.

1. Open a new project in Revit by the following steps:

Open Revit ➜ click “New” button ➜ click “Browse” in New Project browser to open template (CIC_Template_STR.rte for Superstructure Plans; CIC_Template_DML.rte for Demolition Plan; CIC_Template_CVL.rte for Hoarding Plan) ➜ click “OK”



[image: ]

[image: ][image: ]



2. Create Site Boundary

In the project browser, click “Site” plan under the Structural Plan of View.

[image: ]

Insert CAD drawing of block plan to the view, click “Insert” ➜ “Link CAD”

[image: ]

Move the CAD link towards the location of the project base point such that the point A of the site boundary and the project base point are is overlapped.

[image: ]

Open a structural plan in Revit, click “Massing & Site” ➜ “Modify Site” ➜ “Property Line” to add property line.

[image: ][image: ]





Add site boundary symbol in plan view (Refer to section 7.1.4 Add annotation symbol)

[image: ]

		Category

		Family

		Type



		Generic Annotation

		ANN-GNN-CIC-Site_Boundary_Mark

		/











3. Set the project base point (for civil model only):

[image: ]Inside Site Plan ➜ Click “Manage” in ribbon ➜ “Project Location” ➜” Coordinates”➜ click “Specify Coordinates at Point”.

[image: ]Select one of the site boundary points. In the dialogue box, type the true coordination of the point.






In the same view, select the survey point, click the clip to change its state to unclipped.





[image: ]Move the survey point towards the project base point so that they are overlapped. Then click the clip to change its state to clipped.





4. Create a grid and level

[image: ]Open a structural plan in Revit, click “Architecture” ➜ “Datum” to create a grid in the model accordance according to a specific design.





[image: ]Open an elevation in Revit, click “Architecture” ➜ “Datum” to create a level in the model accordance according to a specific design.











5. Acquire a shared coordinate system from the civil model (for structure and demolition models only)



[image: ][image: ]In the project browser, open Level 0 plan under Structural Plan of View. Insert CAD drawing of block plan to the view, click “Insert” ➜ “Link CAD”



Move the CAD link towards the location of the project base point such that the intersection of Grid A and Grid 1 is placed in the project base point.

[image: ]



Create grids and site boundary.

[image: ]


Link civil model file to the view, click “Insert” ➜ “Link Revit”



[image: ]



Move and rotate the civil model so that their site boundary and grids are overlapped.

[image: ]



Select the civil model, in the properties panel, click “Not Shared” in “Shared Site” ➜ select “Acquire the shared coordinate system form xxx.rvt” -> click “Reconcile”.

[image: ]



Select the survey point, click the clip to change its state to unclipped.





Move the survey point towards the project base point so that they are overlapped. Then click the clip to change its state to clipped.



Save the project.








[bookmark: _Toc59392376]

[bookmark: _Toc59392377]

4 [bookmark: _Toc59392378]Creating Model Objects



4.1 [bookmark: _Toc59392379]Superstructure

The following objects will be modelled in the structural plan:

· Slab

· Column

· Wall

· Beam

· Lift Shaft

· Staircase

· Water Tank

· Reinforcement







4.1.1 Create a Slab

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Floor” ➜ click “Floor: Structural”

[image: ]



In the properties panel, you may choose the specific types of the slab from floor family or create by your own. Adjust the value for “Height Offset From Level”.

[image: ]















Create the slab by drawing boundary line ➜ select “Span Direction” ➜ click “tick”.

[image: ]

[image: ]







Repeat the above steps.



[image: ]





Add level difference symbol and span direction symbol in plan view (Refer to section 7.1.4 Add annotation symbol)



		Category

		Family

		Type



		Generic Annotation

		ANN-GNN-CIC-Level_Difference

		/



		Generic Annotation

		ANN-GNN-CIC-Span_Direction

		Two Way Slab - 2.5mm One Way Slab  - 2.5mm

Cantilever  Slab - 2.5mm





[image: ]





4.1.2 Create Column

[image: ]Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Column”.



In the properties panel, you may choose the specific types of the column from column family or create by your own. Adjust the value for “Base Level”, “Base Offset”, “Top Level” and “Top Offset”.
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[image: ]

[image: ]In the properties panel, type column mark in “Mark” of identity data. For example, C1A was typed for column mark in this case. ➜ place Place the column into designed location.

















Repeat the above steps.

[image: ]





Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Structural Column

		ANN-SCG-CIC

		Mark







[image: ]







4.1.3 Create Wall

Open a structural plan in Revit ➜ Click “Architecture” in the ribbon ➜ “Build” ➜ click “Wall” ➜ click “Wall: Structural”.

[image: ][image: ]





In the properties panel, you may choose the specific types of the wall from column family or create by your own.

[image: ]



In the properties panel, place the wall by setting  base  constraint and top  constraint  to  demonstrate  the floor extension of the wall. Adjust the value for “Base Constraint”, “Base Offset”, “Top Constraint” and “Top Offset”.





[image: ]





Drag the wall from the start point to end point.

[image: ]

In the properties panel, type wall mark in “Mark” of identity data. For example, W5B was typed for wall mark in this case.

[image: ]





Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Wall

		ANN-WLG-CIC

		Mark

Type Mark







[image: ]



4.1.4 Create Beam

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Structure” ➜ click “Beam”

[image: ]

In the properties panel, you may choose the specific types of the beam from beam family or create by your own.

[image: ]





Create the slab by drawing start point and end point ➜ Enter the value for “Start Level Offset” and “End Level Offset” or “Z Offset Value” for beam or inverted beam in the constraint of properties.



[image: ]

[image: ]In the properties panel, add beam mark in “Mark” of identity data. For example, TB18 was typed for beam mark in this case.

[image: ]In Structural group, tick the property “Cantilever” or “Transfer” to identify the specific beam.







Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)

[image: ]

		Category

		Family

		Type



		Structural Framing

		ANN-FRG-CIC-Rectangular

		Standard
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4.1.5 Create Lift Shaft

Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Opening” ➜ click “Shaft”

[image: ]

Create the shaft by drawing boundary line / using detail line on plan ➜ click “symbolic line” to create cross indication for shaft ➜ click “tick”.

[image: ]

[image: ]

In the properties panel, enter the value for base constraint, base offset, top constrain and top offset to control the shaft location and level.

[image: ]



4.1.6 Create a Staircase

Open a structural plan in Revit ➜ Click “Architecture” in ribbon ➜ “Circulation” ➜ click “Stair”

[image: ]



[image: ]Click “Run” ➜ Create the staircase by drawing start point to end point, and landing on plan ➜ click “tick”.

In the properties panel, use the base level, top top-level and offset to control the staircase location and level.

[image: ]

[image: ]







4.1.7 Create a Water Tank

[image: ]Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ “Model” ➜ ”Component” ➜ click “Model In-Place”

Select “Generic Models” in the Family Category and Parameters dialogue and fill in the name of the water tank.




Draw the water tank by using “Forms” tools.



[image: ]

[image: ]







4.1.8 Create Reinforcement (Beam / Column / Wall / Staircase / Water Tank)

[image: ]After the creation of Beam, Column, Wall, Staircase ➜ Open a structural plan in Revit ➜ right click the plan in project browser ➜ click “Duplicate View” to duplicate the plan ➜ click “Duplicate”





[image: ]Create column rebar plan ➜ click “View” ➜ “Graphics” ➜ click “Visibility/ Graphics” to show the column and rebar in plan only.



[image: ]Unclick all items, except “Structural Column” and “Structural Rebar” in Visibility/ Graphics window ➜

click “Apply” ➜ click “OK”.







Only column is shown in on the screen.







Select a column ➜ click “Reinforcement” in ribbon ➜ click “Rebar”.





[image: ]

[image: ]



Select the “Placement Plane” in ribbon Ribbon ➜ select “current work plane / near cover reference / far cover reference” to place the rebar plane.





Create a stirrup ➜ In the properties panel, you may choose the specific rebar bar and rebar shape from rebar family or create by your own.

[image: ][image: ]

[image: ]





[image: ]





Change the rebar spacing in rebar set of ribbonRibbon.

[image: ]

[image: ]Change the quantity of rebar and direction in rebar set of ribbonRibbon.



[image: ]



Repeat the above step for mains and links.



[image: ]

Repeat the above steps for Beam and Wall.



Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Structural Rebar

		ANN-RBG-CIC

		[image: ]







[image: ]








4.1.9 Create Reinforcement (Path)

After the creation of Slab ➜ Click “Structure” in ribbon ➜ “Reinforcement” ➜ Click “Path”

[image: ]

Select the floor ➜ Sketch the line of the path on the floor.



[image: ]



[image: ]



In the properties panel, fill in the information of “Layout Rule”, “Additional Offset”, “Face”, “Bar Spacing”, “Primary Bar – Type”, “Primary Bar – Length”, “Primary Bar – Shape”, “Primary Bar – Start Hook”, “Primary Bar – End Hook”.

For “Rebar Layer”, fill in T1/T2/B1/B2, etc.



[image: ]

Select the structural path reinforcement symbol. In the properties panel, select  “ANN-PHG-CIC-Symbol (Top)” for top layer rebar and “ANN-PHG-CIC-Symbol (Bottom)” for bottom layer rebar.





Add path reinforcement symbol in plan view

Click “Annotation” in ribbon ➜ ”Symbol” ➜ click “Path”.

[image: ]

Select between “Top” or “Bottom” for a different layer of the rebar.

[image: ]



[image: ]

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)

[image: ]

		Category

		Family

		Type



		Structural Path Reinforcement

		ANN-PHG-CIC-Tag

		Standard
















4.1.10 Create Reinforcement (Area)

After the creation of Slab ➜ Click “Structure” in ribbon ➜ “Reinforcement” ➜ Click “Area”

[image: ]

Select the floor ➜ sketch the boundary of slab to form a closed loop



[image: ]

A parallel line symbol indicates the major direction edge of the area reinforcement.

[image: ]For major direction, tick “Top Major Direction” and “Bottom Major Direction” in the properties panel. Select the “Top Major Bar Type” and “Top Major Spacing”. Set the value of “Bottom Major Bar Type “and “Bottom Major Spacing”,





Copy the previous Structural Area Reinforcement object and paste “Aligned to the Same Place” as the rebars for minor direction.

[image: ]For minor direction, tick “Top Minor Direction” and “Bottom Minor Direction” in the properties panel. Select the “Top Minor Bar Type” and “Top Minor Spacing”. Set the value of “Bottom Minor Bar Type “, “Bottom Minor Spacing”, “Additional Top Cover Offset” and “Additional Bottom Cover Offset”.



[image: ]



[image: ]Go to 3D View, there are four layers of rebars. Select the first layer of rebars and add “T1” to Comments in the properties panel. Select the second layer of rebars and add “T2” to Comments. For  the bottom layer of rebar, add “B2” to Comments for the third layer and add “B1” to Comments for the fourth layer.





Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)

[image: ]

		Category

		Family

		Type



		Structural Area Reinforcement

		ANN-ARG-CIC

		Major / Minor







4.2 [bookmark: _Toc59392380]Demolition including hoarding

The following objects will be modelled in the demolition plan:

· Existing Building Structure

· Bamboo Scaffolding

· Propping

· Debris Chute

· Video Camera





The following objects will be modelled in hoarding plan:

· Topo surface

· Counterweight

· Hoarding

· Railing

· Street Furnitures (Traffic Light / Fire Hydrant / Pillar Box / Street Light)







4.2.1 Create an Existing Building Structure

[image: ]Steps of creating existing building structure can be referred to Section 4.1 “Superstructure”. Structural wall, beam, slab and shaft are created.





4.2.2 Create Bamboo Scaffolding

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”.

[image: ]

In the properties panel, you may choose the specific types of scaffolding from family “GMD-TMP-CIC- Bamboo_Scaffolding” or create by your own.



[image: ]





[image: ]Create the scaffolding by stretch starting point to end point



Repeat the above steps.
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[image: ]






4.2.3 Create Propping

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”.

[image: ]

In the properties panel, you may choose the specific types of propping from family “GMD-TMP-CIC- Propping” or create by your own. Place it to the desired location.

[image: ]



[image: ]





Repeat the above steps.

[image: ]






4.2.4 Create Debris Chute

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”.

[image: ]

In the properties panel, you may choose the specific types of debris chute from family “GMD-TMP-CIC- Debris_Chute” or create by your own. Place it to the desired location.



[image: ]

Dimension can be adjusted by clicking “Edit Type” in properties panel ➜ type the dimensions of width

 / length / height by your own to suit the design ➜ click “OK”.

[image: ]



[image: ]

Repeat the above steps.

[image: ]



4.2.5 Create a Video Camera

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”.

[image: ]




In the properties panel, you may choose the specific types of debris chute from family “SCD-CTV-CIC- Wall_Mounted” or create by your own. Place it to the desired location.










4.2.6 Create Topographic Surface

Insert CAD as a reference to create a 3D topo surface.

[image: ]Open a site plan in Revit ➜ click “Insert” in Ribbon ➜ click “Link CAD”➜ find the CAD location ➜ click “OK”





[image: ]



[image: ]

Open a site plan in Revit ➜ click “Massing & Site” in ribbon ➜ click “Toposurface” under Model Site.

[image: ]

[image: ]Place point and set the elevation on the Toposurface to create ➜ click “Tick”.

[image: ]





[image: ]

Repeat the above steps for other Toposurface with different levels.

[image: ]






4.2.7 Create Counterweight

Open a site plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”.

[image: ]

In the properties panel, you may choose the specific types of counterweight from family

“STE-LGT-CIC-Counterweight-2 / 3 / 4 posts” or create by your own. Place it to the desired location.



[image: ]

Repeat the above steps.

[image: ]










4.2.8 Create Hoarding

[image: ]Open a site plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”.



In the properties panel, you may choose the specific types of hoarding from family

“STE-LGT-CIC-Hoarding-Gantry / Double Deck / Corner” or create by your own. Place it to a the desired location.

Adjust Angle for the sloped surface.



[image: ]

[image: ]Repeat the above steps.












4.2.9 Create Railing

Open a site plan in Revit ➜ click “Architecture” in ribbon ➜ click “Railing”.

[image: ]

In the properties panel, you may choose the specific type of counterweight from family “ste-lgt-CIC- Counterweight-2 / 3 / 4 posts” or create on your own. Drag the railing from a start point to end. Place it to the desired location.

[image: ]

[image: ]

Repeat the above steps.












4.2.10 Create Street Furnitures (Traffic Light/Fire Hydrant/Pillar Box/Street Light)

Open a structural plan in Revit ➜ click “Structure” in ribbon ➜ click “Component”

[image: ]

In the properties panel, you may choose the specific types of elements from family or create by your own. Place it to the desired location.







Repeat the above steps.
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4.3 [bookmark: _Toc59392381]Foundation

The following objects will be modelled in a foundation plan:

· Pile Cap

· Bored Pile

· Socket H-Pile

· Tie Beam

· Screen Wall

· Foundation Slab

· Column/Wall above pile cap



4.3.1 Create Pile Cap

Open a pile cap level plan in Revit ➜ Click “Structure” in ribbon ➜ click “Foundation” ➜ click “Slab” ➜

 “Structural Foundation: Slab”

[image: ]



[image: ][image: ]





In the properties panel, you may choose the specific types of the slab from foundation slab family or create by your own.



[image: ]

[image: ]



Type slab mark in “Mark” of identity data. For example, CP1 was typed for slab mark in this case.







Click “Edit Type” in Properties browser ➜ Under Type Parameter ➜ Under Other ➜ Select the Foundation_Type as “FD_Cap” to ensure the filtering function of template format can be functionablefunctional.



[image: ]






[image: ]

Use Draw tool to create a slab by drawing a boundary line ➜ click “Tick” when finishing



[image: ]



Repeat the above steps.

[image: ]



Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)

[image: ]

		Category

		Family

		Type



		Structural Foundation

		ANN-FDG-CIC-Rectangular

		Mark & FDN Thickness
















4.3.2 Create Bored Pile

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click “Foundation” ➜ click “Isolated

[image: ]

In the properties panel, you may choose the specific types of a pile from pile family “SFD-FPL-CIC- Bored_Pile” or create by your own.

[image: ]

[image: ]Type pile mark in “Mark” of identity data. For example, BP3 was typed for the mark in this case ➜ place the pile into the designed location.





Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)

[image: ]

		Category

		Family

		Type



		Structural Foundation

		ANN-FDG-CIC-Bored_Pile

		Mark & Size

Mark









4.3.3 Create Socket H-Pile

[image: ]Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click “Foundation” ➜ click “Isolated”



In the properties panel, you may choose the specific types of the pile from pile family “SFD-FPL-CIC- Socket_H_Pile” or create by your own.

[image: ]Create the pile by setting cap thickness, pile length, socket length and height offset in constraint. The  universal beam dimension and steel plate dimension of the pile can be set in “Edit Type”.

[image: ]



Type pile mark in “Mark” of identity data. For example, SP2B was typed for the mark in this case. ➜

place Place the pile into designed location.

[image: ]






Repeat the above steps.

[image: ]

Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Structural Foundation

		ANN-FDG-CIC-Rectangular

		Mark Only





[image: ]



4.3.4 Create Tie Beam

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click “Foundation” ➜ click “Isolated”.



[image: ]

[image: ]In the properties panel, you may choose the specific types of the beam from family “SFD-FBM-CIC- Rectangular” or create by your own.

[image: ]Click “Place on Work Plane” in ribbon Ribbon ➜ draw the beam from starting point to end at the center centre of slabs.





Type beam mark in “Mark” of identity data. For example, TB10 was typed for the mark in this case.



[image: ]








Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)

[image: ]

		Category

		Family

		Type



		Structural Foundation

		ANN-FDG-CIC-Rectangular

		Standard 2 Lines

Standard









4.3.5 Create Screen Wall

Open a pile cap level plan in Revit ➜ click “Structure” in ribbon ➜ click “Wall”.

[image: ][image: ]



In the properties panel, you may choose the specific types of a wall from family or create by your own ➜ set  the “Base Constraint” and “Top Constraint” of screen wall height.

Type wall mark in “Mark” of identity data. For example, BW10 was typed for the mark in this case.

[image: ]









Draw the screen wall from starting point to end.



Repeat the above steps.

[image: ]










4.3.6 Create Foundation Slab

Click “Structure” in ribbon ➜ click “Foundation” ➜ click “Slab” ➜ “Structural Foundation: Slab”



[image: ]

[image: ]

In the properties panel ,you may choose the specific types of the slab from foundation slab family or create byon  your own.

[image: ]

Use Draw tool to create a slab by drawing a boundary line ➜ click “Tick” when finishing

[image: ]





Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Structural Foundation

		ANN-FDG-CIC-Rectangular

		Mark







Add level difference symbol and span direction symbol in plan view (Refer to section 7.1.4 Add annotation symbol)
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		Category

		Family

		Type



		Generic Annotation

		ANN-GNN-CIC-Level_Difference

		/



		Generic Annotation

		ANN-GNN-CIC-Span_Direction

		Two Way Slab - 2.5mm One Way Slab  - 2.5mm

Cantilever  Slab - 2.5mm





[image: ]







4.3.7 Create Column/Wall

[image: ]Open a structural plan in Revit ➜ Click “Structure” in ribbon ➜ click “Column”/”Wall”.



[image: ]

[image: ][image: ]In the properties panel, you may choose the specific types of a column from column family or create by your own.







In the properties panel, type column mark in “Mark” of identity data. For example, PC2 was typed for column mark in this case. ➜ place Place the column into designed location.

[image: ]

[image: ]





Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Structural Column

		ANN-SCG-CIC

		Mark



		Wall

		ANN-WLG-CIC

		Mark





[image: ]



4.4 [bookmark: _Toc59392382]Excavation and lateral support

The following objects will be modelled in a foundation plan:

· Sheet Pile

· Walling

· Struct / Tie / Short Struct

· Stage Topo / Final Topo

· Basement Wall



4.4.1 Create Sheet Pile

In the Project Browser, open an existing ground level Click “Structural” in ribbon ➜ click “Isolated”

[image: ]

In the Properties panel, select family type “SFD-FPL-CIC-Sheet_Pile” ➜ change “Offset” to set level ➜

[image: ]click Click “Edit Type” to change properties by your own if any



Click “Place on Work Plane” ➜ Drag from starting point to end to create sheet pile

[image: ]



[image: ]

Repeat the above steps







4.4.2 Create Walling

In the Project Browser, open an existing ground level

Click “Insert” ➜ click “Load Family” ➜ Open “SFM-STB-CIC-UB.rfa” file in Browser ➜ click “Open” Remark: repeat the above steps to load different types can be loaded into the model

[image: ][image: ]



Select the required type to load into the project.



[image: ]

In Ribbon, click “Structure” ➜ draw walling by dragging starting point to end

[image: ]In the Properties panel, select the corresponding type and dimension of walling ➜ fill in “mark” for identification of element ➜Fill in “ELS_Phase” to identify the phasing (i.e. 1,2,3,4 …etc)

Set cross cross-section rotation if necessary

[image: ]



[image: ]







4.4.3 Create Strut / Short Strut / Tie

[image: ]In Ribbon, click “Structure”  ➜ click “BEAM” ➜ drag from starting point to end to create the strut / tie     /short strut

In the Properties panel, select the  corresponding type and dimension  ➜  select the reference level ➜   Fill       in “Mark” for identification of element ➜ Fill in “ELS_Phase” to identify the phasing (i.e. 1,2,3,4 …etc.)

[image: ]

[image: ]





Repeat the above steps

[image: ]





Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Structural Framing

		ANN-FTG-CIC-Rectangular

		Standard



		Structural Column

		ANN-SCG-CIC

		Mark













4.4.4 Create Stage Topo / Final Topo

In Ribbon, click “Massing & Site” ➜ click “Toposurface” ➜ Input surface “Elevation” ➜ click “Place Point” on specific elevation ➜ click “Tick” ➜ Repeat above steps for different elevations

[image: ][image: ]



[image: ]

[image: ]In the Properties panel, fill in “ELS_Phase” and “Name” to identify the phasing (i.e. 1,2,3,4 …etc.) and the  name of the toposurface (i.e. 1,2,3,4 …etc.). Select “Earth” for Material.

For final excavation toposurface, fill in “Final” for Name and select “Final Excavation Level” for Material.

[image: ]



[image: ]



Add Symbol in plan view (Refer to section 7.1.4 Add annotation symbol)



		Category

		Family

		Type



		Generic Annotation

		ANN-GNN-CIC-Cut_Slope

		5mm

10mm







Add spot elevation for final excavation in plan view

[image: ]In ribbon ➜ click “Annotate” ➜ “Spot Elevation” ➜ select “SPE-AEC-Final_Excavation_Level_Prefix” in properties panel ➜ place to the desired location.



4.5 [bookmark: _Toc59392383]Ground Investigation

The following objects will be modelled:

· Bored Hole

· Standard penetration tests result

· Profile for inferred boundaries of different geological strata

· Instrument checkpoints



4.5.1 Insert Bored Hole using Dynamo

Prepare the bored hole coordination table in excel format for dynamo input. Basic information shall be input by the user:

· Bored hole number

· Soil / rock layer

· Easting coordination



· Northing coordination

· Layer top top-level (mPD)

· Layer bottom level (mPD)

[image: ]

Click “Manage” in ribbon ➜ click “Dynamo”

(Remark: User may download Dynamo from the below website: https://dynamobim.org/download/)

[image: ]

Open dynamo user interface in window ➜ Open dynamo file “bh_gen(v1.3.4).dyn”

[image: ]
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[image: ]

[image: ]Click to edit “File Path” ➜ Choose the corresponding excel file of the bored hole coordination table.



Edit “Family Type” in Dynamo window ➜ change the type to “STE-OTR-CIC-Borehole: STE-OTR-CIC- Borehole”

[image: ]

[image: ]Click “Run” in Dynamo window



Close the Dynamo window ➜ present bored hole elements in Revit screen



[image: ]



4.5.2 Insert Standard penetration test result using Dynamo

Prepare a standard penetration test point table in  excel format for dynamo input.  Basic information shall  be input by user:

· Count

· Easting

· Northing

· Position Z

· Value

[image: ]

Click “Manage” in ribbon ➜ click “Dynamo” again for standard penetration test (SPT) input

[image: ]

Open dynamo user interface in window ➜ Open dynamo file “spt_gen(v1.3.4).dyn” Click to edit “File Path” ➜ Choose the corresponding excel file

[image: ]Edit “Family Type” in  Dynamo  window  ➜  change  the  family  type  to “STE-OTR-CIC-Borehole_SPT: STE-OTR-CIC-Borehole_SPT”



[image: ]Click “Run” in Dynamo window



Close the Dynamo window ➜ present SPT elements in Revit screen Select a bored hole ➜ edit the rockhead level manually.















































Important Note:

In the properties panel, “soil layer”, “Diameter”, “Base Elevation”, “Easting”, “Northing”, “Rock Head Level”, “Mark” are automatically generated by Dynamo input from previous steps.





Add Tag in plan view/ section view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Site

		ANN-STG-CIC-Boredhole

		Elevation – Layer Elevation – Mark Elevation - N Value Plan – Down

Plan - Up







[image: ]



[image: ]










4.5.3 Create rockhead profile

In Ribbon, click “Insert” ➜ click “Import CAD” ➜ select the rockhead CAD file

[image: ]

[image: ]Make sure to unclick “Current view only” ➜ place the CAD file to the desired location.





[image: ]

In Ribbon, click “Massing & Site” ➜ click “Toposurface”

[image: ]

Click “Select Import Instance” ➜ select the imported rockhead CAD file

[image: ]

Select the layer(s) that contains the elevation points of the profile ➜ click “OK” to generate the toposurface.



[image: ]

[image: ]In properties panel, fill in “BH Rock” for Name.









4.5.4 Create profile for inferred boundaries of different geological strata

Select “BOREDHOLE” plan under Floor Plans in Project Browser. In Ribbon, click “Insert” ➜ click

Open a site plan in Revit ➜ click “Massing & Site” in ribbon ➜ click “Toposurface” under Model Site.

[image: ]



[image: ]Place point and set the elevation on the Toposurface according to the inferred boundaries for each bored hole ➜ click “Tick”.

[image: ]

[image: ]



[image: ]



[image: ]In the properties panel, fill in the name of each boundary (ie. BH MD, BH ALLU, BH CDG, etc.) in “Name”



4.5.5 Create Instrument check point

The followings instrument check point object will be modelled:

· Building settlement marker

· Building Tilting check point with vertical displacement

· Ground settlement check point

· Utility settlement monitoring point on ground

· Vibration check point

· Observation Well

· Pump Well

· Recharge Well

· Standpipe with piezometer

Select “MONITORING CHECK POINT” plan  under Floor  Plans in Project  Browser.  In Ribbon, click “Massing & Site” ➜ click “Site Component”

[image: ]

Select the specific types of instrument marker in the properties panel.



[image: ]



[image: ]Place the object to the designed location.





[image: ]In the properties panel, fill in “Name” for identification of element. Select Up/Down/Left/Right for the display location of the name.



4.6 [bookmark: _Toc59392384]Site Formation

The following objects will be modelled for site formation plan:

· Site formation profile

· Site drainage

· Retaining wall

· Soil nail



4.6.1 Create Site formation profile

[image: ]Open a “SITE FORMATION” plan under Floor Plans in Project Browser ➜ click “Massing & Site” in ribbon ➜ click “Toposurface” under Model Site.

Place point and set the elevation on the Toposurface to create ➜ click “Tick”.

[image: ]



[image: ][image: ]

Repeat the above steps for a different stage of site profile.

In the properties panel, fill in “SF” for Name for identification of element.
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[image: ]





Add Symbol in plan view (Refer to section 7.1.4 Add annotation symbol)



		Category

		Family

		Type



		Detail Item

		DTL-OTR-CIC-Slope_Label

		Soil Cut Slope Soil Fill Slope Rock Cut Slope

Rock Fill Slope







Add Spot slope in plan view

[image: ]In ribbon ➜ click “Annotate” ➜ “Spot Slope” ➜ select “Sloped Toposurface” in properties panel ➜ place  to the desired slope.

[image: ]



4.6.2 Create Site drainage

Open “SITE FORMATION” plan under Floor  Plans  in Project  Browser. In Ribbon, click “Massing & Site” ➜ click “Site Component”

[image: ]

[image: ]Select “STE-STU-CIC-Step_Channel” or “STE-STU-CIC-U_Channel” in the properties panel.

Click “Place on Work Plane” ➜ Drag from starting point to end to create the channel.

[image: ]

[image: ]

Channel sizes can be adjusted by clicking “Edit Type” in the properties panel. “Type Comments” define the text showing on the plan view.



[image: ]



4.6.3 Create Retaining wall

[image: ]Open “SITE FORMATION” under Floor Plans in Project Browser ➜ Click “Structure” in ribbon ➜

“Model” ➜ ”Component” ➜ click “Model In-Place”



Select “Site” in the Family Category and Parameters dialogue and fill in the name of retaining wall. Draw the retaining wall by using “Forms” tools.

[image: ]



[image: ]







4.6.4 Create Soil nail

Open “Site Formation 3D” under 3D Views in Project Browser. In Ribbon, click “Massing & Site” ➜ click “Site Component”

[image: ]

Select “STE-OTH-CIC-Soil_Nail” in the properties panel.

[image: ]

[image: ]Place it to the designed location along the surface of the toposurface.





[image: ]In the properties panel, fill in “Name” for identification of element.







Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Site

		ANN-STG-CIC-Soil_Nail

		Up

Down





[image: ]









4.7 [bookmark: _Toc59392385]Drainage

The following objects will be modelled for drainage plan:

· Drainage pipe

· Drain

· Sanitary fitment

· Manhole / Sump Pit / Gully / Trap / Petrol Interceptor



4.7.1 Create Drainage pipe

In Ribbon, click “System” ➜ click “Pipe” under “Plumbing & Piping”

[image: ]

[image: ]Select the specific system type in the properties panel.



In the properties panel, specific the System Type of the pipe.

[image: ]

Under ribbon panel, select pipe diameter and offset from level.

[image: ]

Specific the slope value for the sloped pipe.



[image: ]

Drag from starting point to end to create the pipe.

[image: ]



Add slope symbol to the sloped pipe

[image: ]In ribbon  ➜ click  “Annotate”  ➜ “Spot  Slope”  ➜ select  “Pipe Direction” in properties  panel  ➜ place to the desired pipe.

In the properties panel, fill in 0mm to “Offset from Reference”.

[image: ]



[image: ]



4.7.2 Create Drain

In Ribbon, click “System” ➜ click “Plumbing Fixture” under “Plumbing & Piping”

[image: ]

Select the specific drain type in the properties panel.

[image: ]

Place it to the designed location.



[image: ]

Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Plumbing Fixture

		ANN-PMG-CIC

		Type Mark (RWP)

Type Mark (WP)









4.7.3 Create Sanitary fitment

In Ribbon, click “System” ➜ click “Plumbing Fixture” under “Plumbing & Piping”

[image: ]

Select the specific sanitary fitment item in properties panel ➜Place it to the designed location



[image: ]







4.7.4 Create Manhole / Sump Pit / Gully / Trap / Petrol Interceptor

In Ribbon, click “System” ➜ click “Plumbing Fixture” under “Plumbing & Piping”

[image: ]

[image: ]Select the specific item in properties panel ➜Place it to the designed location
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Add Tag in plan view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Family

		Type



		Plumbing Fixture

		ANN-PMG-CIC

		Detail (RWP) Detail (SWP)

Detail (WP)









4.8 [bookmark: _Toc59392386]Curtain Wall

The following objects will be modelled for curtain wall plan:

· Embed

· Mullion and transom

· Glass panel and louvre













4.8.1 Create Embed

In Ribbon, click “Structure” ➜ click “Component” under “Model”

[image: ]

Select the specific item in properties panel ➜Place it to the designed location

[image: ]



4.8.2 Create mullion and transom

Create Curtain wall by clicking “Architecture” ➜ “Wall” ➜ select “Curtain Wall” in the properties panel

[image: ]

Create curtain grid by clicking “Architecture” ➜ “Build” ➜“Curtain Grid”



[image: ]



[image: ]

Add mullion by clicking “Architecture” ➜ “Build” ➜“Mullion” ➜Select the specific type of mullion     in properties➜ Place it to the designed curtain grid location

[image: ][image: ]



4.8.3 Create glass panel / louvre

For each panel inside, select the type of curtain wall panel in properties.



[image: ]

[image: ]



5 [bookmark: _Toc59392387]Configuring Schedules



5.1 [bookmark: _Toc59392388]Superstructure



5.1.1 Column Schedule

Click “COLUMN SCHEDULE” in Schedules/Quantities (all) of Project Browser.

[image: ]



		Auto generated field

		COLUMN MARK, SIZE



		Manually Input field

		/









5.1.2 Tower Floor Level Schedule

Click “TOWER FLOOR LEVEL” in Schedules/Quantities (all) of Project Browser.

[image: ]



		Auto generated field

		LEVEL, S.F.L.



		Manually Input field

		/









5.1.3 Wall RC Schedule

Click “R.C. WALL SCHEDULE” in Schedules/Quantities (all) of Project Browser.



[image: ]



[image: ]



		Auto generated field

		FLOOR, WALL MARK, THICKNESS



		Manually Input field

		CONCRETE GRADE, VERTICAL BARS, HORIZONTAL BARS, BINDER (HORIZONTAL), BINDER(VERTICAL), STEEL RATIO









5.1.4 Beam RC Schedule

[image: ]Click “R.C. BEAM SCHEDULE” in Schedules/Quantities (all) of Project Browser.

[image: ]





		Auto generated field

		BEAM MARK, BEAM SIZE



		Manually Input field

		ELEV. REFER, REINFORCEMENT (a-g), REINFORCEMENT (Links 1-3), DIMENSION (A-D)







5.2 [bookmark: _Toc59392389]Foundation



5.2.1 Bored Pile Loading Schedule

Click “BORED PILE LOADING SCHEDULE” in Schedules/Quantities (all) of Project Browser.

[image: ]



[image: ]



[image: ][image: ]

		Auto generated field

		BORED PILE MARK, BORED PILE DIAMETER, PILE BASE DIAMETER, CUT-OFF LEVEL, TENTATIVE FOUNDING LEVEL



		Manually Input field

		BORED PILE CAP THICKNESS, BORED PILE EFFECTIVE SHAFT DIAMETER, ROCK SOCKET DIAMETER, BELLOUT DEPTH, TENTATIVE ROCKHEAD LEVEL, TENTATIVE PILE LENGTH, EFFECTIVE ROCK SOCKET LENGTH, SELF-WEIGHT OF BORED PILE (SUBMERGED)

(SWP), Dmin (total), SDL(total), LIVE LOAD (LL) (total), Wmax (total), TOTAL UPLIFT FORCE DUE TO GROUND WATER (U), ADDITIONAL LOAD DUE TO STEPPING EFFECT, VERTICAL BARS, LINKS, PILE BARING CAPACITY (COMPRESSION), ROCK FRICTION (COMPRESSION), ROCK FRICTION (TENSION), ROCK/SOIL MASS (SUBMERGED), REFERENCE BORED HOLE







5.2.2 Socket H-Pile Loading Schedule

[image: ]Click “SOCKET H-PILE LOADING SCHEDULE” in Schedules/Quantities (all) of Project Browser.



[image: ]



[image: ]

[image: ]

		Auto generated field

		PILE MARK, CUT-OFF LEVEL, TENTATIVE ROCKHEAD LEVEL, TENTATIVE FOUNDING LEVEL



		Manually Input field

		PILE CAP THICKNESS, NUMBER OF PILES PER CAP, TENTATIVE PILE LENGTH, EFFECTIVE ROCK SOCKET LENGTH, Dmin, SDL, LIVE LOAD (LL), Wmax, UPLIFT FORCE DUE TO GROUND WATER (U), SELF- WEIGHT (SUBMERGED) (SWP), ADDITIONAL LOAD DUE TO STEPPING EFFECT, COMPRESSION CAPACITY (PER PILE), TENSION CAPACITY (TENSION), ROCK/SOIL MASS (SUBMERGED) (PER PILE), REFERENCE BORED HOLE









5.2.3 Column Loading Schedule above Pile Cap

Click “COLUMN LOADING SCHEDULE ABOVE PILE CAP” in Schedules/Quantities (all) of Project Browser.



[image: ]



[image: ]

[image: ]

[image: ]



		Auto generated field

		COLUMN MARK, DEAD LOAD (DL), DL + LL,



		Manually Input field

		ANGLE, MIN DEAD LOAD (Dmin), SDL, LIVE LOAD (LL), W0, W90, WU, WV, WMAX









5.2.4 Wall Loading Schedule above Pile Cap

Click “WALL LOADING SCHEDULE ABOVE PILE CAP” in Schedules/Quantities (all) of  Project Browser.

[image: ]

[image: ]

[image: ]

[image: ]

		Auto generated field

		WALL MARK, DEAD LOAD (DL), DL + LL,



		Manually Input field

		ANGLE, MIN DEAD LOAD (Dmin), SDL, LIVE LOAD (LL), W0, W90, WU, WV, WMAX









5.2.5 Tie Beam R.C. Details Schedule

Click “TIE BEAM R.C. DETAILS SCHEDULE” in Schedules/Quantities (all) of Project Browser.

[image: ]

[image: ]



		Auto generated field

		TIE BEAM MARK, BEAM SIZE, LENGTH, TIE BEAM TOP LEVEL, TOP LEVEL (Lv1), TOP LEVEL (Lv2),



		Manually Input field

		PILE CAP (P1), PILE CAP (P2), STEEL BAR, LINK, SECTION REFERENCE, ELEVATION REFERENCE













5.2.6 Ground Investigation Table of Rock Head

[image: ]Click “GROUND INVESTIGATION TALBE OF ROCK HEAD” in Schedules/Quantities (all) of Project Browser.



		Auto generated field

		DRILL HOLE MARK



		Manually Input field

		ROCKHEAD LEVEL









5.3 [bookmark: _Toc59392390]Excavation and Lateral Support



5.3.1 Schedule of Horizontal Tie

[image: ]Click “SCHEDULE OF HORIZONTAL TIE” in Schedules/Quantities (all) of Project Browser.





		Auto generated field

		ITEM, GRADE, MEMBER SIZE



		Manually Input field

		MEMBER MARK









5.3.2 Schedule of Main Strut

[image: ]Click “SCHEDULE OF MAIN STRUT” in Schedules/Quantities (all) of Project Browser.





		Auto generated field

		WALING MEMBER SIZE,



		Manually Input field

		PILE TYPE, LAYER, PRELOAD, PRELOAD PER STRUT, HORIZONTAL LOAD, DESIGN LOAD FOR STRUT











5.3.3 Schedule of Secondary Strut and Corner Strut

[image: ]Click “SCHEDULE OF SECONDARY STRUT AND CORNER STRUT” in Schedules/Quantities (all) of Project Browser.



		Auto generated field

		STRUT LEVEL, WALING MEMBER SIZE



		Manually Input field

		PILE TYPE, LAYER











5.3.4 Schedule of Vertical Tie

Click “SCHEDULE OF VERTICAL TIE” in Schedules/Quantities (all) of Project Browser.

[image: ]



		Auto generated field

		ITEM, GRADE, MEMBER SIZE



		Manually Input field

		MEMBER MARK











5.3.5 Schedule of Wailing

Click “SCHEDULE OF WAILING” in Schedules/Quantities (all) of Project Browser.
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[image: ]



		Auto generated field

		WALING MEMBER SIZE



		Manually Input field

		PILE TYPE, LAYER, COMPRESSION, SHEAR, MOMENT









5.3.6 Section Properties of Horizontal Tie

[image: ]Click “SECTION PROPERTIES OF HORIZONTAL TIE” in Schedules/Quantities (all) of Project Browser.



		Auto generated field

		ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE THICKNESS T



		Manually Input field

		/











5.3.7 Section Properties of Short Strut/ Spacer

[image: ]Click “SECTION PROPERTIES OF SHORT STRUT / SPACER” in Schedules/Quantities (all) of Project Browser.



		Auto generated field

		ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE THICKNESS T



		Manually Input field

		/











5.3.8 Section Properties of Struts

Click “SECTION PROPERTIES OF STRUTS” in Schedules/Quantities (all) of Project Browser.



[image: ]



		Auto generated field

		ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE THICKNESS T



		Manually Input field

		/









5.3.9 Section Properties of Vertical Tie

[image: ]Click “SECTION PROPERTIES OF VERTICAL TIE” in Schedules/Quantities (all) of Project Browser.





		Auto generated field

		ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE THICKNESS T



		Manually Input field

		/











5.3.10 Section Properties of Wailing

Click “SECTION PROPERTIES OF WAILING” in Schedules/Quantities (all) of Project Browser.

[image: ]



		Auto generated field

		ITEM, GRADE, SECTION AREA, MOMENT OF INERTIA, WEIGHT, SECTION MODULUS, DEPTH D, WIDTH B, WEB THICKNESS t, FLANGE THICKNESS T



		Manually Input field

		/











5.3.11 Sheet Pile Schedule

Click “SHEET PILE SCHEDULE” in Schedules/Quantities (all) of Project Browser.



[image: ]



		Auto generated field

		MEMBER SIZE, TOE LEVEL



		Manually Input field

		SHEET PILE TYPE, MAX RETAINING HEIGHT, MIN EMBEDMENT LENGTH, FINAL EXCAVATION LEVEL, GRADE









5.3.12 Sheet Pile Section Properties

Click “SHEET PILE SECTION PROPERTIES” in Schedules/Quantities (all) of Project Browser.

[image: ]



		Auto generated field

		DIMENSIONS, SECTION AREA (PER PILE), MOMENT OF INERTIA (PER PILE), WEIGHT (PER PILE), SECTION MODULUS (PER PILE), SECTION AREA (PER 1m PILE), MOMENT OF INERTIA (PER 1m PILE), WEIGHT (PER 1m PILE), SECTION MODULUS (PER 1m PILE)



		Manually Input field

		MEMBER SIZE











5.3.13 Instrument Schedule

[image: ]Click “INSTRUMENT SCHEDULE” in Schedules/Quantities (all) of Project Browser.





		Auto generated field

		TYPE



		Manually Input field

		SYMBOL, NUMBER







5.4 [bookmark: _Toc59392391]Drainage



5.4.1 Strom Water Manhole Schedule

[image: ]



		Auto generated field

		DEPTH



		Manually Input field

		MANHOLE NO., PIPE DIAMETER, C.L., I.L., D.T.I.L., TYPE







5.4.2 Foul Water Manhole Schedule

[image: ]



		Auto generated field

		DEPTH



		Manually Input field

		MANHOLE NO., PIPE DIAMETER, C.L., I.L., D.T.I.L., TYPE







5.4.3 Petrol Interceptor Schedule

[image: ]



		Auto generated field

		DEPTH



		Manually Input field

		PETROL INTERCEPTOR NO., C.L., I.L., B.L.







5.4.4 Sump Pit Schedule

[image: ]



		Auto generated field

		SUMP PIT SIZE



		Manually Input field

		SUMP PIT NO., C.L., I.L., B.L., PUMP NO., PUMP DUTY







6 [bookmark: _Toc59392392]Standardizing Standardising View Setting

This template has defined the desired settings. The users can use view templates to manage these settings. B by applying the view template, user efficiency on projects enhanced by assigning default view template for each view type. The standardized standardised view properties include, but not limited to, view scale, detail level, model display setting.





Open either view plan ➜ On the “View” tab ➜ find the “Graphics” panel ➜ select “View Templates” ➜

select “Apply Template Properties to Current View”

[image: ]

[image: ]

In “View Templates” dialogue box ➜ on the right, select the view template applied to the corresponding view ➜ click “OK” to close the window.

Changes to view templates are automatically reflected in the views to which they have been assigned.





6.1 [bookmark: _Toc59392393]Superstructure

The following view templates can be applied into view:



		View Type

		View template name



		Plans

		CIC_Block Plan	CIC_Structural Framing Plan

CIC_Column RC Detail	CIC_Wall RC Detail

CIC_Slab RC Detail	CIC_Water Tank Layout Plan

CIC_Structural Loading Key Plan	CIC_Stairs Layout Plan CIC_Water Tank Layout Plan



		Sections / Elevations

		CIC_Beam RC Detail	CIC_Stairs RC Detail

CIC_Water Tank Section View



		3D Views

		CIC_Structural 3D











6.2 [bookmark: _Toc59392394]Demolition including hoarding

The following view templates can be applied into view:



		View Type

		View template name



		Plans

		CIC_Block Plan

CIC_Demolition Plan CIC_Hoarding Layout Plan



		Sections / Elevations

		CIC_Hoarding Section View



		3D Views

		CIC_Structural 3D









6.3 [bookmark: _Toc59392395]Foundation

The following view templates can be applied into view:



		View Type

		View template name



		Plans

		CIC_Block Plan	CIC_ Pile Cap RC Plan (Shear) CIC_Column/Wall Layout Plan	CIC_Piling Layout Plan CIC_Loading Intensity Plan	CIC_Pile Cap Layout Plan

CIC_Pile Cap RC Plan (Rebar)	CIC_Monitoring Plan (FDN)



		Sections / Elevations

		CIC_Pile Cap RC Section

CIC_Piling Section View



		3D Views

		CIC_Structural 3D







6.4 [bookmark: _Toc59392396]Excavation and lateral support

The following view templates can be applied into view:



		View Type

		View template name



		Plans

		CIC_Block Plan CIC_ELS Layout Plan

CIC_Monitoring Plan (ELS)



		Sections / Elevations

		CIC_ELS Elevation View CIC_ELS Section View

CIC_ELS Section View (SEQ)



		3D Views

		CIC_ELS 3D









6.5 [bookmark: _Toc59392397]Site Formation

The following view templates can be applied into view:

	

		View Type

		View template name



		Plans

		CIC_Block Plan

CIC_Site Formation Layout Plan



		Sections / Elevations

		CIC_Site Formation Section View



		3D Views

		CIC_ Site Formation 3D









6.6 [bookmark: _Toc59392398]Drainage

The following view templates can be applied into view:



		View Type

		View template name



		Plans

		CIC_Drainage Layout Plan



		Sections / Elevations

		CIC_Drainage Schematic Diagram



		3D Views

		/









6.7 [bookmark: _Toc59392399]Curtain Wall

The following view templates can be applied into view:



		View Type

		View template name



		Plans

		CIC_Curtain Wall Cast-in Layout Plan CIC_Curtain Wall Location Plan

CIC_Embed Plan View



		Sections / Elevations

		CIC_Curtain Wall Cast-in Section View







		

		CIC_Curtain Wall Elevation CIC_Curtain Wall Section View

CIC_Embed Section View







7 [bookmark: _Toc59392400]Preparing Drawing Production



7.1 [bookmark: _Toc59392401]Duplicating Views

For drawing production, the users may duplicate the view for further editing instead of the working view.

[image: ]Select a structural plan  ➜ right click ➜ click “Duplicate View” ➜ “Duplicate” ➜ re-naming the sheet    to “DEMOLITION PLAN – EXISTING FRAMING PLAN” or re-naming by your own.







7.1.1 Add Tags (Tag All not tagged)

Click “Annotation” in ribbon ➜ click “Tag All” for column and beam marks.

[image: ]



[image: ]Click both “Structural Column Tags” and “Structural Framing Tags” in below Window ➜ click “OK”.



Choose “ANN-FTG-CIC-Rectangular” or “ANN-SCG-CIC” for the standard markings of beam and column respectively.

[image: ] [image: ]

[image: ]
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7.1.2 Add Tags (Tag by Category)

Click “Annotation” in ribbon ➜ click “Tag by Category” for column and beam marks.

[image: ]

[image: ]Click “Tags..” in Option bar.



[image: ]Assign the required tag family and type to each category and click “OK”.



Click the desired object to tag.



7.1.3 Add Dimensions

Create the grid dimension from “Aligned” under Dimension in ribbonRibbon.

[image: ]





Choose “CIC_2.5_Con_Diagonal” under Linear Dimension Style family for the standard style of dimension.



[image: ]



[image: ]

[image: ]





7.1.4 Add Annotation Symbols

Click “Annotation” in ribbon ➜ click “Symbol” to place annotation symbols.

[image: ]



Select the specific type of symbol from “Properties”.



[image: ]



Place it to desired location.

[image: ]



7.2 [bookmark: _Toc59392402]Create Drafting View

Despite of creating 3D objects, 2D information can also be drafted in the drafting view when appropriate. For example, general notes and typical details.

[image: ]Click “Drafting View” under Create in View ➜ Re-naming the drafting view to “GENERAL NOTES FOR DEMOLITION” or by your own for easy reference.



7.2.1 Text Note

Insert text from the annotation.



[image: ]

In the properties panel, choose the specific type of text.

[image: ][image: ]





7.2.2 Typical Details

[image: ]Create detail line / region.





[image: ]

Create lines and choose different Line Style.

[image: ]

Drafting the region by drawing tools.





[image: ][image: ]
Examples of Detail for Demolition Works:



[image: ]




[bookmark: _Toc59392403]

7.3 [bookmark: _Toc59392404]Create Legend

Click “View” in ribbon ➜ click “Legends” to create a new legend view.

[image: ]

[image: ]Use Annotation tool such as text, filled region and symbols to create the components in legends.



[image: ]

Example of legends that already created in the Structural template.



[image: ]



7.4 [bookmark: _Toc59392405]Create Drainage Schematic Diagram



7.4.1 Create Elevation View

[image: ]Create an exterior elevation view in plan ➜adjust the width and length of the crop region







7.4.2 Add Tags to non-pipework drainage object

Add Tag in elevation view (Refer to section 7.1.2 Add Tags – Tag by Category)



		Category

		Tag family

		Drainage object



		Plumbing Fixture

		ANN-PMG-CIC-Schem-Floor_Drain

ANN-PMG-CIC-Schem-Vertical_Floor_Drain ANN-PMG-CIC-Schem-Water_Closet

		Floor_Drain Vertical_Floor_Drain

Water_Closet







Drag the tags to the location manually.



[image: ]



7.4.3 Add detail item to routing of pipes

Click “Annotation” in ribbon ➜ click “Component” in “Detail” to place detail item.

[image: ]



In “Properties”, select “CIC_Pipe Line” ➜select the specific type of line

[image: ]

		Family

		Type

		Graphics



		CIC_Pipe Line

		DR-Waste

DR-Waste with arrow DR-Waste with radius

		[image: ]



		CIC_Pump Symbol

		WP

		[image: ]



		CIC_Room Boundary

		F. LAV

		[image: ]



		CIC_Sunken

		D1800

		[image: ]











7.4.4 Apply view template

Apply view template “CIC_Drainage Schematic Diagram” to the view. (Refer to section 6 Standardizing Standardising View Setting)




[bookmark: _Toc59392406]

8 [bookmark: _Toc59392407]Creating Sheet



8.1 [bookmark: _Toc59392408]Sheet List

Using a template sheet, the users can create a tabular view of sheets in a project. From “View” tab in ribbon ➜ click “Schedule” ➜ click “Sheet List”.

In the field tab of the sheet list properties dialog box, add the field name sheet number, sheet name, sheet issue date and sheet revision to the list of scheduled fields.

[image: ]To begin adding sheets to the sheet list, go to the row panel in ribbon ➜ click “Insert” ➜ click “Data Rows”. The users can continue populating the schedule in this way.



8.1.1 Superstructure

For superstructure submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		S001

		GENERAL NOTES FOR SUPERSTRUCTURE



		S002

		TYPICAL FLOOR FRAMING PLAN



		S003

		BEAM R.C. SCHEDULE



		S004

		BEAM R.C. DETAIL (SCHEDULE VERSION)



		S005

		BEAM R.C. DETAIL



		S006

		COLUMN R.C. DETAIL



		S007

		WALL R.C. DETAIL (1 OF 2)



		S007A

		WALL R.C. DETAIL (Schedule)



		S008

		WALL R.C. DETAIL (2 OF 2)







		S009

		SLAB R.C. DETAIL



		S010

		STAIRCASE R.C. DETAIL



		S011

		WATER TANK R.C. DETAIL









8.1.2 Demolition including hoarding

For Demolition submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		D001

		GENERAL NOTES FOR DEMOLITION



		D002

		DEMOLITION PLAN – EXISTING G/F, 1/F FRAMING PLAN



		D003

		DEMOLITION DETAILS (BY HAND HELD TOOLS)



		D004

		DETAIL FOR DEMOLITION WORKS (1/2)



		D005

		DETAIL FOR DEMOLITION WORKS (2/2)



		H001

		HOARDING LAYOUT PLAN



		H002

		HOARDING TYPICAL DETAIL









8.1.3 Foundation

For Foundation submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		P001

		GENERAL NOTES FOR FOUNDATION



		P002

		PILING LAYOUT PLAN



		P003

		PILING SECTION A & SECTION B



		P004

		PILING SECTION C



		P005

		COLUMN / WALL LOADING PLAN



		P006

		COLUMN / WALL LOADING SCHEDULE



		P007

		LOADING INTENSITY PLAN



		P008

		PILE LOAD SCHEDULE



		P009

		MONITORING PLAN



		P010

		PILE CAP REINFORCEMENT LAYOUT PLAN



		P010A

		PILE CAP REINFORCEMENT LAYOUT PLAN (2 OF 2)



		P011

		COLUMN AND WALL STARTER DETAILS



		P012

		TIE BEAM DETAILS & SCHEDULE



		P013

		PILE CAP LAYOUT PLAN



		P014

		GENERAL NOTES FOR PILE CAP
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8.1.4 Excavation and Lateral Support

For Excavation and lateral support submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		E001

		EXCAVATION & LATERAL SUPPORT GENERAL NOTES



		E002

		EXCAVATION & LATERAL SUPPORT LAYOUT PLAN



		E003

		EXCAVATION & LATERAL SUPPORT SECTIONS (1 OF 2)



		E004

		EXCAVATION & LATERAL SUPPORT SECTIONS (2 OF 2)



		E005

		EXCAVATION & LATERAL SUPPORT CONSTRUCTION SEQUENCE (1 OF 2)



		E006

		EXCAVATION & LATERAL SUPPORT CONSTRUCTION SEQUENCE (2 OF 2)



		E007

		EXCAVATION & LATERAL SUPPORT ELEVATION



		E008

		EXCAVATION & LATERAL SUPPORT WORKS MONITORING PLAN



		E009

		EXCAVATION & LATERAL SUPPORT WORKS PUMPING TEST SETTING OUT PLAN









8.1.5 Ground Investigation

For Ground Investigation submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		/

		/









8.1.6 Site Formation

For Site Formation submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		T001

		GENERAL NOTES FOR SITE FORMATION



		T002

		SITE FORMATION LAYOUT PLAN



		T003

		SITE FORMATION SECTIONS









8.1.7 Drainage

For Site Formation submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		M001

		GENERAL NOTES FOR DRAINAGE



		M002

		SCHEMATIC DIAGRAM OF DRAINAGE SYSTEM



		M003

		DRAINAGE LAYOUT PLAN FOR TYPICAL FLOOR







		M004

		DRAINAGE INSTALLATION DETAILS



		M005

		DRAINAGE SCHEDULES







8.1.8 Curtain Wall

For Site Formation submission, this template shows the following examples for your reference.



		Sheet Number

		Sheet Name



		C001

		GENERAL NOTES FOR CURTAIN WALL



		C002

		CURTAIN WALL LOCATION PLAN



		C003

		CURTAIN WALL CAST-IN LAYOUT PLAN



		C004

		DETAIL OF EMBED AND MEMBER SECTION PROPERTIES



		C005

		CURTAIN WALL PARTIAL ELEVATIONS AND SECTIONS







8.2 [bookmark: _Toc59392409]Title Block

[image: ]The title block includes standardized standardised view and location of BD’s approval stamp chop and RSE’s name chop.



8.3 [bookmark: _Toc59392410]Examples of sheets

[image: ]Examples of sheets can be found in Sheet (all) from the project browser.





8.3.1 Superstructure



8.3.1.1 General Notes

[image: ]From the project browser, click “S001 - GENERAL NOTES FOR SUPERSTRUCTURAL” in Sheet (all). The sheet consists of general notes and block plan, as basic components.



Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		BLOCK PLAN



		Drafting view

		NOTES FOR SUPERSTRUCTURE









8.3.1.2 Typical Floor Framing Plan

From project browser, click “S002 - TYPICAL FLOOR FRAMING PLAN” in Sheet (all). The sheet consists of notes, legend, plans and schedules, as basic components.

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		TYP FLOOR FRAMING PLAN

TYP FLOOR LOADING KEY PLAN



		Drafting view

		LOADING KEY PLAN

FRAMING PLAN NOTES



		Schedule

		COLUMN SCHEDULE

TOWER FLOOR LEVEL



		Legend

		FRAMING PLAN LEGEND









8.3.1.3 Beam R.C. Detail

From the project browser, click “S003 – BEAM R.C. SCHEDULE” in Sheet (all).



[image: ]Drag beam R.C. detail from drafting view into the sheet. 3

Drag the following views to the sheet.



		View Type

		View Name



		Schedule

		R.C. BEAM SCHEDULE



		Drafting View

		BEAM RC DETAIL









8.3.1.4 Beam R.C. Detail

From project browser, click “S004 – BEAM R.C. DETAIL” in

[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Section

		CTB1 SECTION 1, CTB1 SECTION A, CTB56 SECTION 1, CTB56 SECTION B, CTB56 SECTION C









8.3.1.5 Column R.C. Detail

From project browser, click “S005 – COLUMN R.C. DETAIL” in Sheet (all).

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		COLUMN REBAR PLAN (C1-C10)



		Drafting View

		COLUMN REBAR TABLE

COLUMN CRITICAL ZONE COLUMN BEAM JOINT DETAIL














8.3.1.6 Wall R.C. Detail

From the project browser, click “S006 – WALL R.C. DETAIL (1 OF 2)” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		5F WALL REBAR PLAN (WALL DETAIL 1-5)



		Legend

		WALL RC DETAIL LEGEND



		Schedule

		R.C. WALL SCHEDULE









8.3.1.7 Wall R.C. Detail (Schedule)

From project browser, click “S007 – WALL R.C. DETAIL (Schedule)” in Sheet (all).

[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		WALL DETAIL (SCHEDULE) 1

WALL DETAIL (SCHEDULE) 2



		Drafting View

		WALL REBAR TABLE









8.3.1.8 Slab R.C. Detail

[image: ]From project browser, click “S009 – SLAB R.C. DETAIL” in Sheet (all).



Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		TYP FLOOR SLAB R.C. DETAILS












8.3.1.9 Staircase R.C. Detail

From the project browser, click “S010 – STAIRCASE R.C. DETAIL” in Sheet (all).



[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		ST1, ST2



		Section

		STAIRS RC DETAIL  (ST-01)

STAIRS RC DETAIL  (ST-02)







8.3.1.10 Water Tank R.C. Detail

[image: ]From the project browser, click “S011 – WATER TANK R.C. DETAIL” in Sheet (all).
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Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		2/F Water Tank



		Section

		WATER TANK SECTION 1

WATER TANK SECTION 2







8.3.2 Demolition including hoarding



8.3.2.1 General Notes

From the project browser, click “D001 - GENERAL NOTES FOR DEMOLITION” in Sheet (all). The sheet consists of general notes and title block, as basic components.

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		BLOCK PLAN



		Drafting View

		GENERAL NOTES FOR DEMOLITION









8.3.2.2 Demolition Plan – Existing G/F, 1/F Framing Plan

From the project browser, click “D002 – DEMOLITION PLAN – EXISTING G/F, 1/F FRAMING PLAN” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		DEMOLITION PLAN - EXISTING G/F FRAMING PLAN

DEMOLITION PLAN - EXISTING 1/F FRAMING PLAN



		Legend

		CIC_DEMOLITION PLAN









8.3.2.3 Demolition Details (By Hand Held Tools)

From the project browser, click “D003 – DEMOLITION DETAILS (BY HAND HELD TOOLS)” in Sheet (all).



[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		TYPICAL SEQUENCE OF TOP DOWN METHOD









8.3.2.4 Details for Demolition works

[image: ]From the project browser, click “D004 – DETAIL FOR DEMOLITION WORKS” in Sheet (all).





Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		DETAIL FOR DEMOLITION WORKS (1)

DETAIL FOR DEMOLITION WORKS (2)












8.3.2.5 Hoarding Layout Plan

From the project browser, click “H001 – HOARDING LAYOUT PLAN” in Sheet (all).

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		HOARDING PLAN



		Structural Plan

		HOARDING PLAN

BLOCK PLAN



		Section

		HOARDING (TYPE C) SECTION A1







8.3.2.6 Hoarding Typical Detail

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		HOARDING TYPICAL DETAIL



		Section

		DETAIL 1-7

ELEVATION OF COVERED WALKWAY & GANTRY SECTION A (GANTRY)

TYPICAL SECTINON OF HOARDING TYPE A












8.3.3 Foundation



8.3.3.1 General Notes

From the project browser, click “P001 - GENERAL NOTES FOR FOUNDATION” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		NOTES FOR FOUNDATION









8.3.3.2 Piling Layout Plan

From project browser, click “P002 – PILING LAYOUT PLAN” in Sheet (all).

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Legend

		PILING LAYOUT PLAN



		Structural Plan

		PILING LAYOUT PLAN

BLOCK PLAN









8.3.3.3 Piling Section

[image: ]From project browser, click “P003 – Piling Section A & Section B” or “P004 – Piling Section C” in Sheet (all).

[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Legend

		PILING SECTION



		Section

		PILING SECTION A-C









8.3.3.4 Column/Wall Loading Plan

From project browser, click “P005 – COLUMN / WALL LOADING PLAN” in Sheet (all).

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		COLUMN & WALL LAYOUT PLAN



		Drafting View

		COLUMN WALL LOADING NOTES












8.3.3.5 Column/Wall Loading Schedule

From project browser, click “P006 – COLUMN / WALL LOADING SCHEDULE” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Schedule

		COLUMN LOADING SCHEDULE ABOVE PILE CAP (1 OF 2) COLUMN LOADING SCHEDULE ABOVE PILE CAP (2 OF 2) WALL LOADING SCHEDULE ABOVE PILE CAP (1 OF 2)

WALL LOADING SCHEDULE ABOVE PILE CAP (2 OF 2)









8.3.3.6 Loading Intensity Plan

From project browser, click “P007 – LOADING INTENSITY PLAN” in Sheet (all).

[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		LOADING INTENSITY PLAN AT B2 LOADING INTENSITY PLAN FOR FILL AT B2

LOADING INTENSITY PLAN FOR UPTHRUST AT B2



		Legend

		LOADING INTENSITY









8.3.3.7 Pile Load Schedule

From project browser, click “P008 – PILE LOAD SCHEDULE” in Sheet (all).

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Schedule

		BORED PILE LOADING SCHEDULE (1 OF 2) BORED PILE LOADING SCHEDULE (2 OF 2) SOCKET H-PILE LOADING SCHEDULE (1 OF 2)

SOCKET H-PILE LOADING SCHEDULE (2 OF 2)












8.3.3.8 Foundation Monitoring Plan

From project browser, click “P009 – FOUNDATION MONITORING PLAN” in Sheet (all).
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[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		MONITORING PLAN (FDN)



		Legend

		MONITORING PLAN



		Drafting View

		NOTES FOR MONITORING PLAN



		Schedule

		INSTRUMENT SCHEDULE

GROUND INVESTIGATION TALBE OF ROCK HEAD












8.3.3.9 Pile Cap Reinforcement Layout Plan

From project browser, click “P010 – Pile Cap Reinforcement Layout Plan” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		PILE CAP REBAR PLAN - F1 PILE CAP SHEAR PLAN - F1 PILE CAP REBAR PLAN - F5

PILE CAP SHEAR PLAN - F5



		Legend

		SHEAR LINK DIAGRAM (PILE CAP)



		Section

		SECTION A-D












8.3.3.10 Column and Wall Starter Details

From project browser, click “P011 – Column and Wall Starter Details” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Structural Plan

		PILE CAP COLUMN REBAR PLAN - PC1-TC10



		Legend

		STARTER BAR LEGEND



		Schedule

		WALL STARTER BAR SCHEDULE



		Drafting View

		STARTER BAR DETAIL

STARTER BAR TABLE












8.3.3.11 Tie Beam Details and Schedule

From project browser, click “P012 – Tie Beam Details & Schedule” in Sheet (all).



[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Schedule

		TIE BEAM R.C. DETAILS SCHEDULE



		Drafting View

		TIE BEAM RC DETAIL









8.3.3.12 Pile Cap Layout Plan

From project browser, click “P013 – PILE CAP LAYOUT PLAN” in Sheet (all).

[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Legend

		PILE CAPLAYOUT PLAN



		Structural Plan

		PILE CAP LAYOUT PLAN

BLOCK PLAN









8.3.3.13 General Notes for Pile Cap

[image: ]From project browser, click “P014 – GENERAL NOTES FOR PILE CAP” in Sheet (all).



Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		NOTES FOR PILE CAP







8.3.4 Excavation and Lateral Support



8.3.4.1 Excavation and Lateral Support General Notes

From project browser, click “EXCAVATION & LATERAL SUPPORT GENERAL NOTES” in Sheet (all).

[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		NOTES FOR ELS



		Schedule

		SCHEDULE OF HORIZONTAL TIE SCHEDULE OF MAIN STRUT

SCHEDULE OF SECONDARY STRUT AND CORNER STRUT SCHEDULE OF VERTICAL TIE

SCHEDULE OF WAILING

SECTION PROPERTIES OF HORIZONTAL TIE SECTION PROPERTIES OF SHORT STRUT / SPACER SECTION PROPERTIES OF STRUTS

SECTION PROPERTIES OF VERTICAL TIE

SECTION PROPERTIES OF WAILING SOIL PARAMETER














8.3.4.2 Excavation and Lateral Support Layout Plan

From the project browser, click “EXCAVATION & LATERAL SUPPORT LAYOUT PLAN” in Sheet (all).



[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Legend

		ELS LAYOUT



		Structural Plan

		BLOCK PLAN

ELS LAYOUT PLAN



		Schedule

		SHEET PILE SCHEDULE

SHEET PILE SECTION PROPERTIES












8.3.4.3 Excavation and Lateral Support Sections

From project browser, click “EXCAVATION & LATERAL SUPPORT SECTIONS (1 OF 2)” in Sheet (all).



[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Legend

		ELS SECTION



		Section

		ELS SECTION A to ELS SECTION C












8.3.4.4 Excavation and Lateral Support Construction Sequence

From the project browser, click “EXCAVATION & LATERAL SUPPORT CONSTRUCTION SEQUENCE (1 OF 2)” in Sheet (all).



[image: ]

For different phase of construction sequence, it can be set from filter in this template.

Select a section under the drawing ➜ in ribbonRibbon, select “View” ➜ select “Visibility / Graphics”

[image: ]



[image: ]

In a window, select “Filter” ➜ For phase 0, unclick all filter under Visibility ➜ click “OK”

[image: ]

For phase 1, click “ELS – Phase 1” and “Topo - Phase 1” under visibility ➜ click “OK”

[image: ]

For final phase, select all “ELS – Phase 1 to 8” and both “Topo – Phase 8” and “Topo – Final” ➜ click “OK”



150



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		ELS SEQUENCE 2



		Schedule

		SCHEDULE OF HORIZONTAL TIE



		Legend

		ELS SECTION



		Section

		ELS SEQUENCE SECTION (STAGE 0) to ELS SEQUENCE SECTION (STAGE 8)









8.3.4.5 Excavation and Lateral Support Elevation

From the project browser, click “EXCAVATION & LATERAL SUPPORT ELEVATION” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Elevation

		ELS ELEVATION A-B ELS ELEVATION B-C ELS ELEVATION C-D

ELS ELEVATION D-A









8.3.4.6 Excavation and Lateral Support Monitoring Plan

From the project browser, click “EXCAVATION & LATERAL SUPPORT WORKS MONITORING PLAN” in Sheet (all).



[image: ]

Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		NOTES FOR ELS MONITORING



		Legend

		ELS MONITORING



		Structural Plan

		ELS MONITORING PLAN



		Schedule

		INSTRUMENT SCHEDULE












8.3.4.7 Excavation and Lateral Support Pumping test setting out Plan

From the project browser, click “EXCAVATION & LATERAL SUPPORT WORKS PUMPING  TEST SETTING OUT PLAN” in Sheet (all).



[image: ]



Drag the following views to the sheet.



		View Type

		View Name



		Drafting View

		NOTES FOR ELS PUMPING TEST



		Legend

		ELS MONITORING



		Structural Plan

		ELS PUMPING TEST SETTING OUT PLAN



		Legend

		INSTRUMENT SCHEDULE









8.3.5 Site Formation



8.3.5.1 General Notes

From project browser






8.3.6 Drainage



8.3.6.1 General Notes for Drainage

From the project browser, click “GENERAL NOTES FOR DRAINAGE” in Sheet (all).



[image: ]



		View Type

		View Name



		Drafting View

		GENERAL NOTES







8.3.6.2 Schematic Diagram of Drainage System

[image: ]From the project browser, click “SCHEMATIC DIAGRAM OF DRAINAGE SYSTEM” in Sheet (all).





		View Type

		View Name



		Elevation

		Drainage Schematic







8.3.6.3 Drainage Layout Plan for Typical Floor

[image: ]From the project browser, click “DRAINAGE LAYOUT PLAN FOR TYPICAL FLOOR” in Sheet (all).





		View Type

		View Name



		Floor Plans

		6/F FLOOR PLAN



		3D View

		3D View (Right), 3D View (Left)









8.3.6.4 Drainage Installation Details

From the project browser, click “DRAINAGE INSTALLATION DETAILS” in Sheet (all).



[image: ]

		View Type

		View Name



		Drafting View

		DRAINAGE INSTALLATION









8.3.6.5 Drainage Schedules

From the project browser, click “DRAINAGE SCHEDULES” in Sheet (all).

[image: ]



		View Type

		View Name



		Schedule

		FOUL WATER MANHOLE SCHEDULE PETROL INTERCEPTOR SCHEDULE STORM WATER MANHOLE SCHEDULE

SUMP PIT SCHEDULE












8.3.7 Curtain Wall



8.3.7.1 Curtain Wall Layout Plan

From the project browser, click “CURTAIN WALL LAYOUT PLAN” in Sheet (all).



[image: ]



		View Type

		View Name



		Floor Plan

		5/F LAYOUT PART PLAN (FLAT B)







8.3.7.2 Curtain Wall Case-in Layout Plan

From the project browser, click “CURTAIN WALL CAST-IN LAYOUT PLAN” in Sheet (all).

[image: ]



		View Type

		View Name



		Floor Plan

		5/F CAST-IN LAYOUT PLAN (FLAT B)



		Section

		CAST-IN SECTION 1, CAST-IN SECTION 2







8.3.7.3 Detail of Embed and Member Section Properties

[image: ]From project browser, click “DETAIL OF EMBED AND MEMBER SECTION  PROPERTIES” in  Sheet (all).



		View Type

		View Name



		Floor Plan

		5/F EMBED E2 LAYOUT PLAN



		Section

		EMBED (E2) SECTION







8.3.7.4 Curtain Wall Partial Elevations and Sections

[image: ]From project browser, click “CURTAIN WALL PARTIAL ELEVATIONS AND SECTIONS” in Sheet (all).





		View Type

		View Name



		Elevation

		CURTAIN WALL ELEVATION



		Section

		CURTAIN WALL SECTION A







154



9 [bookmark: _Toc59392411]Exporting Models as Deliverables



9.1 [bookmark: _Toc59392412]Exporting 3D models as NWC

Publishing to 3D, the user can create a single 3D representation of the model that can be orbited, control visibility of element categories, and be queried for the properties of any of elements.

Click “Add-ins” ➜ click “Naviswork” and setting ➜ click “OK” to publish a 3D model for sharing.



9.2 [bookmark: _Toc59392413]Exporting 2D models as PDF

Publishing to 2D can create either a single view or a whole collection of interconnected views and sheets packaged as one file.

[image: ]Click  “File”  ➜  click  “Print”  ➜ edit “Properties / File Location  / Print Range  / Settings”  ➜ click  “OK” to publish PDF.




Feedback Form



CIC BIM User Guide for Preparation of Statutory Plan Submissions Revit December 2020





To improve future editions of this publication, we would be grateful to have your comments. 

 

(Please put a "" in the appropriate box.)

		1. As a whole, I feel that the publication is: 

		Strongly 
  Agree

		Agree

		Neutral

		Disagree

		Strongly Disagree



		Informative

		

		

		

		

		



		Comprehensive

		

		

		

		

		



		Useful

		

		

		

		

		



		Practical

		

		

		

		

		



		2. Does the publication enable you to understand more about the subject?

		Yes

		No

		No Comment



		

		

		

		



		3. Have you made reference to the publication in your work?

		Quite Often

		Sometimes

		Never



		

		

		

		



		4. To what extent the publication benefits you?

		Strongly  
  Agree

		Agree

		Neutral

		Disagree

		Strongly Disagree



		Supply chain Information/data integrity

		

		

		

		

		



		Work efficiency

		

		

		

		

		



		Project Collaborations

		

		

		

		

		



		5. Overall, how would you rate our publication?

		Excellent

		Very Good

		Satisfactory

		    Fair

		    Poor



		

		

		

		

		

		



		6. Other comments and suggestions, please specify (use separate sheets if necessary).

 



		Personal Particulars (optional):*

Name:			Mr. / Mrs./ Ms./ Dr./ Prof./ Ar. / Ir / Sr ^

Company: 

Tel: 

Address: 

E-mail:



		







*	The personal data in this form will be used only for this survey. Your data will be kept confidential and dealt with only by the Construction Industry Council.

^	Circle as appropriate.

 

Please return the feedback form to:

CIC Secretariat – BIM

E-mail:              bim@cic.hk;

Address:           38/F, COS Center, 56 Tsun Yip Street, Kwun Tong, Hong Kong

Fax No.: (852) 2100 9090
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