HOW TO SET UP EXCEL SPREADSHEETS TO MEASURE, TRANSFER AND BILL BILLS OF QUANTITIES IN A REAL TIME MANNER

MR. TANG KI-CHEUNG
FHKIS, RPS(QS), AVS, FSZCEA, MHKIVM
DIRECTOR, K C TANG CONSULTANTS LTD., HONG KONG (E-mail kctang@kctang.com.hk)
REPRESENTING THE HONG KONG INSTITUTE OF SURVEYORS

ABSTRACT

It would be ideal if BIM (Building Information Modelling) is mature enough, or if you have proprietary software or in-house software capable of measuring accurate quantities for Bills of Quantities and suit your local method of measurement and your financial capability. What can you do if this is not the case? Traditionally, QSs use paper based dimension sheets and schedules to measure. They may now extensively use Excel to do so. Excel is perfect for one to set up schedules to measure inter-related items. The almost instant calculating capability can save a lot of calculation time. However, great care must be exercised to ensure that the formulae are correct and totals are transferred manually or by formula links to the correct final destinations. This paper is to show how to set up an Excel spreadsheet to measure, transfer and bill in a real time manner. The dimension sheets follow a uniform format with a few simple formulae waiving the need of complicated set-up and formula checking. With the help of simple coding entirely defined by the user, the product quantities are summed up and transferred directly to the quantity column of the Bills of Quantities. Items sharing the same quantities (e.g. tile and screed, plaster and paint, door and ironmongery) can be measured as composite items first which are then broken down into component quantities for billing. This would simplify the measurement. With the demonstration by a real example, it can be seen that the set-up is really very simple but can serve most of the need in an affordable manner.

Keywords: Bills of Quantities, Direct Billing, Excel Spreadsheet, Measure, Take Off.

1. INTRODUCTION

While “Bills of Quantities” is referred to here, this paper is also applicable to the preparation of cost estimates, bills of variations, remeasurement bills, etc. where extensive measurement and billing are required.

When using Excel worksheets (spreadsheets) with calculated data, time has to be spent to set up good looking and meaningful worksheets first and then care must be exercised to ensure that the formulae are correct. Further care must be exercised to ensure that the integrity of the cross-references in the formulae would not be destroyed by reason of insertion, deletion, moving, copying and pasting of cells, columns or rows of data. Some counter-checking measures must be implemented to ensure no errors. The time and effort spent and chances of errors will increase with the number of different worksheets used and the complexity of the formulae used.

This paper presents a Microsoft Office Excel 2003 workbook template where a uniform format is adopted for whatever bills, trades, work sections, elements one is measuring and billing. It uses only a few formulae which generally would not need adjustments.

2. FUNCTIONS USED

The template uses the following Excel functions:

1. PRODUCT(range_of_cells) returns the product of multiplying all the values in the range of cells referenced. Empty or non-numeric cells are ignored.
2. **SUM**(range_of_cells) returns the sum total of all the values in the range of cells referenced. Empty or non-numeric cells are ignored.

3. **SUMPRODUCT**(range_A_of_cells, range_B_of_cells) returns the sum total of the products of multiplying the cells in range A by the correspondingly positioned cells in range B. Empty or non-numeric cells are ignored.

4. **VLOOKUP**(search_value, lookup_table, return_column, FALSE) means that the first column of the lookup_table will be searched for the search_value. “FALSE” requires an exact match but irrespective of upper or lower case. If a match is found, the function returns the value in the return_column in the same row, otherwise, the function returns “#N/A”. It should be noted that the return_column is hard-coded and would not change automatically if the lookup_table is so changed that the return_column position is changed. Manual correction would then be necessary.

5. **IF**(criteria, A, B) returns A if the criteria is matched or, if not, B.

6. **COUNTIF**(range_to_search, search_value) returns the number of occurrences of the search_value in the range_to_search.

7. \{=SUM(IF(criteria, range_A, range_B))\} means that if the criteria involving a range of cells is matched, the cell value at the corresponding position in range_A will be added to the sum to be returned by the formula, otherwise, the cell value at the corresponding position in range_B will be added. To operate on more than one range of cells, the formula needs to be enclosed in curly brackets \{\}, not by typing, but by pressing key F2 to edit the formula cell, then press Ctrl+Shift+Return.

8. **SUMIF**(range_to_search, criteria, range_to_sum) means that if any value in the cells within the range_to_check matches the criteria, the cell value at the corresponding position in the range_to_sum will be added to the sum to be returned by the function. It does not need curly brackets but can handle only one criterion.

9. **ROUND**(number, number_of_digits) rounds the number to the number_of_digits. If the number_of_digits is negative, the number will be rounded to the left of the decimal place, otherwise to the right.

The spaces within the formulae shown above are for the sake of readability only and are not permitted in the actual formulae.

In the formulae given in the paper below, “.row” and “.col.” respectively means the row number and column reference of the cell containing the formula.

“$” is used extensively in the formulae to prefix the column or row reference to anchor it so that the column or row reference would not change when the formula is copied from one cell and pasted onto other cells.

### 3. WORKSHEETS

In the template workbook, there will be three worksheets: “Primary” for generating **Primary Quantities**, “Secondary” for generating **Secondary Quantities** using the Primary Quantities, and **Bill Page** “2.1” for Bill No. 2.1 using the Secondary Quantities. There can be more than one worksheet for different Bill No., but there should be only one Primary Worksheet and one Secondary Worksheet.

The setup of the worksheets should be self-explanatory. Due to limitation of space, explanations are given in this paper only on the hidden formulae used and those less obvious points.
The prefixes “Pri-”, “Sec-” and “Bill-” are used before “Column”, “Row” and “Cell” to denote respectively the Primary, Secondary and Bill Page worksheets.

4. WORK FLOW
The work flow can be presented as follows:

Firstly, as described in Section 5 below, use the Primary Worksheet to measure work items, get the dimensions and timesings from the drawings, multiply them to get the product quantities (Primary Qty), and assign different codes (Primary Codes) for different work items. Secondly, as described in Section 6 below, switch to the Secondary Worksheet, enter the Primary Codes, use formulae to obtain the respective totals of Primary Qty from the Primary Worksheet, process further to generate Secondary Qty, and assign different codes (Secondary Codes) for different work items. Finally, as described in Section 7 below, switch to the Bill Page Worksheet, enter the Secondary Codes, and use formulae to obtain the respective totals of Secondary Qty from the Secondary Worksheet. These will be the BQ Qty of the work items. Assign BQ descriptions. For experienced users, the whole flow can be reversed by writing up BQ Descriptions first and assign Secondary Codes, then Primary Codes, before measuring following the normal flow.

5. PRIMARY WORKSHEET
The Primary Worksheet for generating the Primary Quantities is as follows:

Row 9 means that Beams B3 & B4 are each 10.80 m long, x 2 on each floor x 3 floors on 1/F to 3/F = total 64.80 m long. The beams are reinforced concrete 30 MPa edge beam 250 x 400 mm deep in 120 mm slab.

Figure 2: Primary Worksheet
Dimensions are entered in Pri-Columns D to F between Pri-Rows 5 to 11, and timesings in Pri-Column G to I, with floors, references and units on other columns as shown.

The product of the dimensions and timesings is calculated in the cell in Pri-Column L (Row Qty) in the same row by using “=PRODUCT(D:row:I:row)".

User-defined Short Descriptions to represent the work measured are entered in Pri-Column J. They serve as the Primary Codes for subsequent cross-referencing. Therefore they should be systematic, structured and readily understandable.

6. SECONDARY WORKSHEET

The Secondary Worksheet for generating the Secondary Quantities is as follows:

Figure 3: Secondary Worksheet (left and right)

The Short Descriptions created in the Primary Worksheet are entered in Sec-Cells C12 to C25.
Based on the Short Description in Sec-Column C in the same row, Sec-Cells D12 to D25 use “=SUMIF(Primary!$J$5:$J$11,$C.row,Primary!$L$5:$L$11)” to get the Primary Quantities, being the total of the Row Qty in Pri-Column L having the same Short Descriptions in Pri-Column J.

Sec-Cell D14 means that the sum of all the Row Qty in the Primary Worksheet for “RC 30 Edge beam 250x400 in 120 slab” is 64.80 m.

The Primary Quantities are further processed by multiplying them by values in Sec-Columns E to I to generate Secondary Quantities in Sec-Column L which uses “=PRODUCT(D.row:I.row)”.

Sec-Row 14 means that there is a total of 64.80 m of “RC 30 Edge beam 250x400 in 120 slab” from the Primary Worksheet, x 0.25 m beam width x 0.28 m beam depth below slab = total 4.54 m³ of concrete.

Sec-Row 17 means that the same total length x 0.25 m beam width gives 16.20 m² of soffit formwork.

Sec-Row 20 means that the same total length x 0.29 m beam depth below slab x 2 sides = 35.29 m² of side formwork.

Row 23 means that the same total length x 0.12 m slab edge width = 7.78 m² formwork to side of beam at edge of slab.

Other examples of such further processing are:

<table>
<thead>
<tr>
<th>Primary Quantities</th>
<th>Further processing (where “*” = multiplied by)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column height</td>
<td>* cross section = column concrete;</td>
</tr>
<tr>
<td></td>
<td>* column girth = column formwork</td>
</tr>
<tr>
<td>Beam length</td>
<td>* cross section below slab = beam concrete;</td>
</tr>
<tr>
<td></td>
<td>* beam soffit = soffit formwork;</td>
</tr>
<tr>
<td></td>
<td>* beam side * 2 = side formwork</td>
</tr>
<tr>
<td>Window number</td>
<td>* window width * window height = total window area;</td>
</tr>
<tr>
<td></td>
<td>* window width = total window cill length;</td>
</tr>
<tr>
<td></td>
<td>* (window width + window height * 2) * reveal width = total wall reveal area</td>
</tr>
<tr>
<td>Door number</td>
<td>* door leaf width * door leaf height = total door leaf area;</td>
</tr>
<tr>
<td></td>
<td>* frame or architrave girth per door = total door frame or architrave girth;</td>
</tr>
<tr>
<td></td>
<td>* ironmongery number per door = total ironmongery number</td>
</tr>
<tr>
<td>Room internal area</td>
<td>= ceiling plan area = floor area</td>
</tr>
<tr>
<td>Room internal girth</td>
<td>* ceiling height = wall area;</td>
</tr>
<tr>
<td></td>
<td>= skirting length</td>
</tr>
<tr>
<td>Plaster and paint</td>
<td>= Plaster area = Paint area</td>
</tr>
<tr>
<td>composite area</td>
<td></td>
</tr>
<tr>
<td>Tile and screed composite area</td>
<td>= Tile area = Screed area</td>
</tr>
<tr>
<td>Roof area</td>
<td>= Roof tile area = Roof screed area = Waterpoof area = Insulation area = Levelling screed area</td>
</tr>
</tbody>
</table>

User-defined Codes to represent the BQ descriptions of the Secondary Quantities are entered in Sec-Column J. They should be systematic, structured and readily understandable. RC30-CL, RC30-BM, RC30-WL, FWK-CL, FWK-BM, FWK-WL are such examples which can easily be recognised as combinations of reinforced concrete, 30MPa, formwork, column, beam, wall.

Sec-Rows 6 to 8 are similar to the Primary Worksheet and are provided in the Secondary Worksheet for measurement of quantities going directly to the Bill Page worksheet without being processed into Secondary Quantities.

7. BILL PAGE WORKSHEET
The Bill Page worksheet using the Secondary Quantities is as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>&lt;PROJECT&gt;</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>&lt;CONTRACT&gt;</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Item</td>
<td>Code</td>
<td>Description</td>
<td>Qty</td>
<td>Unit</td>
<td>Rate</td>
<td>Amount</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 4: Bill Page Worksheet

The Codes created in the Secondary Worksheet are entered in Bill-Cells C7 to C24.

Based on the Code in Bill-Column C in the same row, Bill-Cells E7 to E24 use “=ROUND(SUMIF(Secondary!$J$5:$J$26,$C.row,Secondary!L$5:L$26),0)” to get the Secondary Quantities, being the total of the Row Qty in Sec-Column L having the same Codes in Sec-Column J.

The Codes need to be expanded into full descriptions in Bill-Column D.

The above quickly covers the core work flow, but there are other cautions and checks to be observed.

8. CAUTIONS

**Cut and paste:** Moving cell contents around by cutting and pasting should not be done because this would corrupt the integrity of the formulae. Use “copy and paste” to replicate the contents and then delete the original contents. The formula will be replicated in the new cell positions with the formulae correspondingly adjusted to suit.

**Insertion and deletion:** It is recommended to add additional rows or columns by copying the existing similar rows or columns to borrow the format and formulae first and then deleting the unnecessary contents. If empty rows or columns are added, the formulae should be copied over from rows or columns of the same kind.

**Upper and lower boundary rows:** It is common error to insert a row before or after the rows to be summed up without making corrections to the formula to include the inserted rows. To prevent this, each worksheet has at least a pair of specially narrowed rows. Making them narrow and including them as the upper and lower boundaries of the formulae referring to the range of rows between and including them would ensure that insertion can only be done in-between them and the range formula will always include the inserted rows. *This is important!*
Seed rows: Pri-Row 6, Sec-Rows 6 and 12, and Bill-Row 7 serve as the seed row for replication of format and formulae to other rows and should not be changed. Similar actions should be done regularly and finally to ‘refresh’ all formulae of the same kind based on the correct one.

VLOOKUP: Watch out whether the formulae using function VLOOKUP() is disturbed by reason of insertion or deletion of columns.

Assigning sequence number: The Seq Columns of the Primary Worksheet and Secondary Worksheet are for recording the original or logical sequence of the dimension rows just in case of the need for re-sorting back to this sequence after the rows are sorted by any other columns for alternative views. Rather than entering the sequence number one by one, a quick way is to select the relevant cells in the column, e.g. Pri-Cells A6 to A9, and select Edit > Fill > Series > Step value with value 1 to result in a series of numbers.

Advanced filter: A random list of repeating values can be screened to a unique list by selecting menu Data > Filter > Advanced Filter > Copy to another location > Unique records only, and entering the source list range and the destination as follows:

![Advanced filter](image)

Figure 5: Advanced filter

The destination list can be alphabetically sorted by selecting the list, and selecting menu Data > Sort.

This method can be followed to get a unique list of the Short Descriptions as used in the Primary Worksheet, for use in the Secondary Worksheet.

Once a unique list of Short Descriptions is obtained, it can be copied over to the Secondary Worksheet and processed batch by batch. The template shows that the rows are grouped under BEAM CONCRETE, BEAM SOFFIT, BEAM SIDES, and BEAM AND SLAB EDGE so as to concentrate on one type of processing of one batch of Short Descriptions each time.

Insufficient row height: When a BQ Description is too long, the row height automatically set by Excel may sometimes not be tall enough such that the last line may be truncated when printed. This may not be apparent on screen. Manually adjustment of the row height would be required.

9. COUNTER-CHECKS

**Integrity of Units**: Checks should be done to ensure that the Units are consistent with the number of dimensions used during the conversion process from Dimensions \( \rightarrow \) Primary Quantities \( \rightarrow \) Secondary Quantities \( \rightarrow \) BQ Quantities.

Sec-Cells K12 to K25 uses “=VLOOKUP(SC.row,Primary!$J$5:$K$11,2,FALSE)” to look up the first column of the reference table of Pri-Cells “$J$5:$K$11” for the Short Description in Sec-Cell $C$.row and, if found, return the unit in the same row in the 2nd column i.e. Pri-Column K.

Sec-Cells N12 to N25 uses “=VLOOKUP($J$.row,'2.1'!$C$6:$F$25,4,FALSE)” to look up the first column of the reference table of Bill-Cells “$C$6:$F$25” for the Short Description in Sec-Cell $J$.x and, if found, return the unit in the same row in the 4th column i.e. Bill-Column F.
Sum totals: For cross-checking purposes, sum totals of the relevant table columns are given in the Table Footer in the following cells:

1. Pri-Cells L12 and M12 use “=SUM(col.$5: col.$11)”;
2. Sec-Cell D27 uses “=SUM(col.$11: col.$26)”;
3. Sec-Cells L27, M27, Q27 and R27 use “=SUM(col.$5: col.$26)”; and
4. Bill-Cells H26, J26 and K26 use “=SUM(col.$6: col.$25)”. Replication of the columns by “copy and paste” would maintain the same formula pattern.

Times of Row Qty used: Pri-Cells M6 to M10 use “=COUNTIF(Secondary!$C$11:$C$26,$J.row)” to count the number of times the Short Description in Pri-Cell $J.row is used in Sec-Cells $C$11:$C$26, as an indication of the number of times the Primary Quantities are used.

Similarly, Sec-Cells M6 to M8 and M12 to M25 use “=COUNTIF('2.1'!$C$6:$C$25,$J.row)” to count the number of times the Code in Sec-Cell $J.row is used in Bill-Cells $C$6:$C$25, as an indication of the number of times the Secondary Quantities are used.

“0” means not used at all. The check helps ensure that measured quantities are actually used and not left out. Primary Quantities could be used more than once for generating the Secondary Quantities, but the number of uses of similar items should have a consistent pattern. Secondary Quantities should generally be used once for the BQ Quantities.

The following are set up to cross-check between the Primary Worksheet and Secondary Worksheet:

1. Pri-Cell L13 uses “=SUMPRODUCT($L$5:$L$11,$M$5:$M$11)” to get the sum total of the Primary Quantities used for generating the Secondary Quantities by multiplying each Primary Quantity (Column L) by its time of use (Column M) and summing up the total (SUM of the PRODUCTS).
2. Sec-Cell D27 uses “=SUM(D$11:D$26)” to give the total of the Primary Quantities used.
3. The two totals should match. Otherwise, something has gone wrong and should be corrected;
4. Pri-Cell K13 uses \=IF(L13=Secondary!D27,”OK: Sum (Row Qty x Times) = Sum (Primary Qty)”, "Error: Sum (Row Qty x Times) <> Sum (Primary Qty)”).
5. Sec-Cell C27 uses \=IF(Primary!L13=D27,”OK: Sum (Primary Qty) = Sum (Primary Row Qty x Times)”, "Error: Sum (Primary Qty) <> Sum (Primary Row Qty x Times)”).
6. Both help check Pri-Cell L13 and Sec-Cell D27 and display a message beginning with "OK" or “Error”.

Similarly, the following are set up to cross-check between the Secondary Worksheet and Bill Page Worksheet:

1. Sec-Cell L28 uses “=SUMPRODUCT($L$5:$L$26,$M$5:$M$26)” to get the sum total of the Secondary Quantities used as BQ Quantities.
2. Sec-Cell L27 uses “=SUM('2.1'!$E$6:$E$25)” to give the total of the BQ Quantities actually used in the Bill Page Worksheet. The information is shown on the Secondary Worksheet because it would not appear on the final BQ Pages.
3. Due to rounding error, a slight mismatch between the values of the two cells should be expected.

Codes and descriptions: Sec-Column O (BQ Description) uses “=VLOOKUP($J.row ,’2.1’!$C$6:$F$25,2,FALSE)” to lookup the BQ Descriptions (partially) in the
10. FLOOR ANALYSIS

As floor references are entered in Pri-Cells B6 to B10, and Sec-Cells B6 to B8, for each row of dimensions, the quantities per floor or group of floors can be obtained.

The Secondary Quantities of every unique floor reference are analysed in Sec-Columns Q and R. The unique floor references are entered in Sec-Cells Q4 to R4. Additional columns copying the same column format and formulae can be inserted.

Cells under Sec-Columns Q and R use formulae to check the Floor references of the Row Qty and put them in the appropriate columns.

Sec-Cells Q6 to R8 uses ‘‘=(IF(col.$4=$B.row,$L.row,0))’’ to put the Row Qty (Sec-Column L) in the cell if its Floor references (Sec-Column B) matches that in Sec-Row 4 above.

Sec-Cells Q12 to R25 uses a more complicated ‘‘=PRODUCT(SUM(IF((col.$4=Primary!$B$5:$B$11)*($C.row=Primary!$J$5:$J$11),Primary!$L$5:$LS11,"\"\")),SE.row:$I.row)’’.

If the Floor reference in Pri-Column B matches that in Sec-Row 5, and the Short Description (Pri-Column J) matches that in Sec-Column C, then the Row Qty in Pri-Column L will be multiplied by values in the same row in Sec-Columns E to I to give the final result.

The columns are summed at Sec-Cells Q27 and R27 using ‘‘=SUM(col.$5:col.$26)’’.

Sec-Cell Q28 gives a grand total using ‘‘=SUM(P27:S27)’’ with Sec-Columns P and S as the boundaries. This is for checking against the total Row Qty at Sec-Cell L27.

The Bill Page Worksheet also does a floor analysis in Bill-Columns J and K, which are actually replicates of Bill-Column E adopting the same formula. While Bill-Column E gets the Secondary Quantities from Sec-Column L, Bill-Columns J and K get from Sec-Columns Q and R. Bill-Cell J5 uses ‘‘=Secondary!Q4’’ and Bill-Cell K5 uses ‘‘=Secondary!R4’’ to show the corresponding floor references.

The totals of Bill-Cells J26 to K26 should be cross-checked against those in Sec-Cell Q27 to R27.

11. MISCELLANEOUS

Drafting descriptions and coding: While this paper describes the flow from Primary → Secondary → Secondary → Bill Page, BQ descriptions can in fact be drafted up-front with the Codes pre-defined for further use. Having got the BQ descriptions, the Codes would be more systematic, structured and understandable.

Frozen view panes: Frozen view panes can be defined by selecting menu Window > Freeze Panes. The rows above and the columns to the left of the current cell is frozen and always kept in view. The “current cell” are Bill-Cell D7, Sec-Cell D6, and Pri-Cell D6.

Print page headers: The table header in a worksheet and the rows above it is the print page header by defining them as the “rows to repeat at top” by selecting menu File > Page Setup > Sheet.

Print page footers: The print page footer of each worksheet is defined by selecting menu File > Page Setup > Header/Footer and entering the following data (those prefixed with “&” are Excel’s variables):
Word-wrapping: All texts should be word-wrapped within their own cells except for the page header rows and table footer rows, and numeric cells, yet all column widths for numeric cells should be wide enough to make word-wrapping unnecessary.

Alignment: All texts should be horizontally left, centre or right-aligned as shown.

All texts should be vertically top-aligned, except that the Qty, Unit, Rate and Amount cells against the BQ items may be bottom-aligned depending on individual taste.

BQ item references: Bill-Columns A and B (Item) are for the item references. Instead of the traditional “A, B, C …” item references starting on every page, here Bill-Column A is for Bill Number “2.1” while Bill-Column B is for consecutive numbering within the same Bill. Such numbering permits free flowing of the numbering over different pages without being constrained to start with an “A” on every page. Bill-Column A is separated from Bill-Column B to facilitate copying and pasting the same text in Bill-Column A.

The font size of Bill-Column C (Code) should be smaller to avoid word-wrapping of long Codes resulting in taller row than that required by the Description.

Bill-Column D (Description) is for entering BQ Descriptions. Indentation can be applied to headings at the third or lower level of BQ Descriptions (not shown in the template).


Bill-Column H uses “=$E.row*SUM(G.row)” to calculate the Amount, being Qty x Rate. “SUM()” is used on Bill-Column G (Rate) because the Rate cell may sometimes have non-numeric entries like “Rate only”, “Included”, etc. While Bill-Column E (Qty) is anchored by “$”, Bill-Column G (Rate) is not, to facilitate the case where the Rate and Amount pair of columns may be replicated for preparing multiple-rate bills for tender analysis but all referring to the same Bill-Column E (Qty).

Distribution: Bill-Columns C and I to K are for internal references only. They should be hidden for printing.

When distributing the file to others without the intention to disclose the measurement details, all the formulae in Bill-Column E should be converted to values by selecting the entire column, pressing Ctrl+C and selecting menu Edit > Paste Special > Values. The contents of Bill-Column E and I to K can then be deleted, and the Primary Worksheet and Secondary Worksheet also deleted. Of course, back-up before any such process.

12. EPILOGUE

Setting up an Excel worksheet can be very easy. But, because it is so powerful and flexible, it needs to be used with caution and needs a lot of safety belts. It takes a longer time to explain and this paper appears too long to read. This only demonstrates the danger of setting up ad-hoc worksheets. Adoption of a worksheet with a uniform format, proven formulae and safety belts is more desirable.